
CVE catalog
CVE-2024-29041
Express vulnerabilities
- Severity
- Medium · CVSS 6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.79% · Oct 27, 2026
Express.js minimalist web framework for node. Versions of Express.js prior to 4.19.0 and all pre-release alpha and beta versions of 5.0 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode [using `encodeurl`](https://github.com/pillarjs/encodeurl) on the contents before passing it to the `location` header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method impacted is `res.location()` but this is also called from within `res.redirect()`. The vulnerability is fixed in 4.19.2 and 5.0.0-beta.3.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-express | sid | 5.2.1+~cs12.3.9-1 | fixed |
| Debian | node-express | forky | 5.2.1+~cs12.3.9-1 | fixed |
| Debian | node-express | trixie | 4.21.2+~cs8.36.27-2 | fixed |
| Debian | node-express | bookworm | 4.18.2+~4.17.14-1 | vulnerable |
| Ubuntu | node-express | noble | Not reported | vulnerable |
| Ubuntu | node-express | noble | 4.19.2+~cs8.36.21-1ubuntu0.1~esm1 | fixed |
| Npm | express | Not reported | 5.0.0-beta.3 | fixed |
| Ubuntu | node-express | pro | 4.18.2+~cs8.34.50-1 | vulnerable |
| Ubuntu | node-express | pro | 4.19.2+~cs8.36.21-1 | vulnerable |
| Ubuntu | node-express | pro | 4.19.2+~cs8.36.21-1ubuntu0.1~esm1 | fixed |
| Ubuntu | node-express | pro | 4.17.1-3 | vulnerable |
| Ubuntu | node-express | pro | 4.17.1+~cs4.17.13-1 | vulnerable |
| Ubuntu | node-express | pro | 4.17.2+~4.17.13-1 | vulnerable |
| Ubuntu | node-express | pro | 4.17.3+~4.17.13-1 | vulnerable |
| Ubuntu | node-express | pro | 4.17.3+~4.17.13-1ubuntu0.1~esm1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-express | source | sid | 4.19.2+~cs8.36.21-1 | not yet assigned | Not reported | [1068346] |
| Debian | node-express | source | forky | 4.19.2+~cs8.36.21-1 | not yet assigned | Not reported | [1068346] |
| Debian | node-express | source | trixie | 4.19.2+~cs8.36.21-1 | not yet assigned | Not reported | [1068346] |
| Debian | node-express | source | bookworm | (unfixed) | not yet assigned | Not reported | [1068346] |
| Ubuntu | node-express | deb | noble | 4.19.2+~cs8.36.21-1ubuntu0.1~esm1 | Not reported | Not reported | Not reported |
| Npm | express | npm | Not reported | 5.0.0-beta.3 | Not reported | GHSA-RV95-896H-C2VC | Not reported |
| Ubuntu | node-express | deb | pro | 4.19.2+~cs8.36.21-1ubuntu0.1~esm1 | Not reported | USN-7581-1 | Not reported |
| Ubuntu | node-express | deb | pro | 4.17.3+~4.17.13-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2024-29041 | Not reported |
Notes
[bookworm] node-express: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-express]Affected
Details (2)
4.18.2+~4.17.14-1· all · bookwormAffected
usn · node-express · debian · bookworm; usn · node-express · debian · 12
4.18.2+~4.17.14-1· all · bookwormAffected
usn · node-express · debian · bookworm; usn · node-express · debian · 12
[Debian 13 (Trixie)]
- [node-express]Fixed
Details (2)
4.21.2+~cs8.36.27-2· all · trixieFixed · Fixed:
4.19.2+~cs8.36.21-1usn · node-express · debian · 13
4.21.2+~cs8.36.27-2· all · trixieFixed · Fixed:
4.19.2+~cs8.36.21-1usn · node-express · debian · 13
Observed:
References
- [https://access.redhat.com/errata/RHSA-2024:3868]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2024-29041]
- [https://osv.dev/vulnerability/GHSA-rv95-896h-c2vc]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2024-29041]
- [https://osv.dev/vulnerability/USN-7581-1]
- [https://security-tracker.debian.org/tracker/CVE-2024-29041]
- [https://ubuntu.com/security/notices/USN-7581-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2024/wid-sec-w-2024-2036.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [Ubuntu Security Notices (USN)]