
CVE catalog
CVE-2024-31211
wordpress: CVE-2024-31211
- Severity
- Low
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.76% · Oct 25, 2026
WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | wordpress | sid | 7.1.3+dfsg1-1 | fixed |
| Debian | wordpress | forky | 7.1.3+dfsg1-1 | fixed |
| Debian | wordpress | trixie | 6.8.7+dfsg1-0+deb13u1 | fixed |
| Debian | wordpress | trixie-security | 6.8.10+dfsg1-0+deb13u1 | fixed |
| Debian | wordpress | bookworm | 6.1.9+dfsg1-0+deb12u1 | not affected |
| Debian | wordpress | bookworm-security | 6.1.9+dfsg1-0+deb12u1 | not affected |
| Ubuntu | wordpress | 16.04 | 4.3+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 16.04 | 4.3.1+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 16.04 | 4.4+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 16.04 | 4.4.1+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 16.04 | 4.4.2+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 16.04 | 4.4.2+dfsg-1ubuntu1 | vulnerable |
| Ubuntu | wordpress | 18.04 | 4.8.2+dfsg-2 | vulnerable |
| Ubuntu | wordpress | 18.04 | 4.8.3+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 18.04 | 4.9.1+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 18.04 | 4.9.2+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 18.04 | 4.9.4+dfsg-1 | vulnerable |
| Ubuntu | wordpress | 18.04 | 4.9.5+dfsg1-1 | vulnerable |
| Ubuntu | wordpress | 20.04 | 5.2.2+dfsg1-1 | vulnerable |
| Ubuntu | wordpress | 20.04 | 5.2.4+dfsg1-1 | vulnerable |
| Ubuntu | wordpress | 20.04 | 5.3.2+dfsg1-1 | vulnerable |
| Ubuntu | wordpress | 20.04 | 5.3.2+dfsg1-1ubuntu1 | vulnerable |
| Ubuntu | wordpress | 22.04 | 5.7.1+dfsg1-2ubuntu1 | vulnerable |
| Ubuntu | wordpress | 22.04 | 5.8.1+dfsg1-2ubuntu1 | vulnerable |
| Ubuntu | wordpress | 22.04 | 5.8.2+dfsg1-1ubuntu1 | vulnerable |
| Ubuntu | wordpress | 22.04 | 5.8.3+dfsg1-1ubuntu1 | vulnerable |
| Ubuntu | wordpress | 22.04 | 5.8.3+dfsg1-1ubuntu1.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | wordpress | source | sid | 6.4.2+dfsg1-1 | not yet assigned | Not reported | Not reported |
| Debian | wordpress | source | forky | 6.4.2+dfsg1-1 | not yet assigned | Not reported | Not reported |
| Debian | wordpress | source | trixie | 6.4.2+dfsg1-1 | not yet assigned | Not reported | Not reported |
| Debian | wordpress | source | bookworm | Not affected | unimportant | Not reported | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.