
CVE catalog
CVE-2024-3203
DEBIAN-CVE-2024-3203
- Severity
- High · CVSS 8.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.36% · Oct 25, 2026
A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | c-blosc2 | 13 | 2.13.1+ds-3 | fixed |
| Debian | c-blosc2 | 14 | 2.13.1+ds-3 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | c-blosc2 | deb | 13 | 2.13.1+ds-3 | Not reported | DEBIAN-CVE-2024-3203 | Not reported |
| Debian | c-blosc2 | deb | 14 | 2.13.1+ds-3 | Not reported | DEBIAN-CVE-2024-3203 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.