
CVE catalog
CVE-2024-3204
DEBIAN-CVE-2024-3204
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.27% · Oct 25, 2026
A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | c-blosc2 | 13 | 2.13.1+ds-3 | fixed |
| Debian | c-blosc2 | 14 | 2.13.1+ds-3 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | c-blosc2 | deb | 13 | 2.13.1+ds-3 | Not reported | DEBIAN-CVE-2024-3204 | Not reported |
| Debian | c-blosc2 | deb | 14 | 2.13.1+ds-3 | Not reported | DEBIAN-CVE-2024-3204 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.