CVE catalog

CVE-2024-32978

ruby-kaminari: CVE-2024-32978

[CVE catalog]

Severity
Low
Source
[NVD] · [CVE record]
EPSS
0.60% · Oct 25, 2026

Kaminari is a paginator for web app frameworks and object relational mappings. A security vulnerability involving insecure file permissions has been identified in the Kaminari pagination library for Ruby on Rails, concerning insecure file permissions. This vulnerability is of moderate severity due to the potential for unauthorized write access to particular Ruby files managed by the library. Such access could lead to the alteration of application behavior or data integrity issues. Users of affected versions are advised to update to Kaminari version 0.16.2 or later, where file permissions have been adjusted to enhance security. If upgrading is not feasible immediately, review and adjust the file permissions for particular Ruby files in Kaminari to ensure they are only accessible by authorized user.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-kaminarisid1.3.0-1not affected
Debianruby-kaminariforky1.2.2-2not affected
Debianruby-kaminaritrixie1.2.2-1not affected
Debianruby-kaminaribookworm1.2.2-1not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-kaminarisourcesidNot affectedunimportantNot reportedNot reported
Debianruby-kaminarisourceforkyNot affectedunimportantNot reportedNot reported
Debianruby-kaminarisourcetrixieNot affectedunimportantNot reportedNot reported
Debianruby-kaminarisourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References