
CVE catalog
CVE-2024-38311
trafficserver: CVE-2024-38311
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.91% · Oct 25, 2026
Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.8, from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 9.2.9 or 10.0.4, which fixes the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | trafficserver | bookworm | 9.2.5+ds-0+deb12u4 | fixed |
| Debian | trafficserver | bookworm-security | 9.2.5+ds-0+deb12u4 | fixed |
| Ubuntu | trafficserver | 16.04 | 5.3.0-2ubuntu1 | vulnerable |
| Ubuntu | trafficserver | 16.04 | 5.3.0-2ubuntu2 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.0.0-5 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-2 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-2build1 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-3 | vulnerable |
| Ubuntu | trafficserver | pro | 8.1.1+ds-1.1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2build1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1+esm1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.1+ds-1build1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.2+ds-1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build3 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build4 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1ubuntu0.1 | vulnerable |
| Ubuntu | trafficserver | 25.10 | 9.2.5+ds-1ubuntu1 | vulnerable |
| Ubuntu | trafficserver | 25.10 | 9.2.5+ds-1ubuntu2 | vulnerable |
| Ubuntu | trafficserver | 25.10 | 9.2.5+ds-1ubuntu2.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | trafficserver | source | bookworm | 9.2.5+ds-0+deb12u2 | not yet assigned | Not reported | [1099691] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [trafficserver]Fixed
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
- [trafficserver-dev]Fixed
Source package: [trafficserver]
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
Source package: [trafficserver]
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u2dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2024-38311]
- [https://osv.dev/vulnerability/DSA-5896-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2024-38311]
- [https://security-tracker.debian.org/tracker/CVE-2024-38311]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-0497.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database]