
CVE catalog
CVE-2024-45409
Ruby SAML vulnerabilities
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 10.68% · Oct 25, 2026
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-saml | bookworm | 1.13.0-1+deb12u1 | fixed |
| Debian | ruby-saml | bookworm-security | 1.13.0-1+deb12u1 | fixed |
| Ubuntu | ruby-saml | noble | 1.15.0-1ubuntu0.24.04.1 | fixed |
| Ubuntu | ruby-saml | pro | 1.4.1-1 | vulnerable |
| Ubuntu | ruby-saml | pro | 1.7.2-1 | vulnerable |
| Ubuntu | ruby-saml | pro | 1.7.2-1ubuntu0.1~esm1 | fixed |
| Ubuntu | ruby-saml | 20.04 | 1.7.2-1 | vulnerable |
| Ubuntu | ruby-saml | 20.04 | 1.11.0-1 | vulnerable |
| Ubuntu | ruby-saml | 20.04 | 1.11.0-1ubuntu0.1 | fixed |
| Ubuntu | ruby-saml | 22.04 | 1.11.0-1 | vulnerable |
| Ubuntu | ruby-saml | 22.04 | 1.13.0-1 | vulnerable |
| Ubuntu | ruby-saml | 22.04 | 1.13.0-1ubuntu0.1 | fixed |
| Ubuntu | ruby-saml | 24.04 | 1.15.0-1 | vulnerable |
| Ubuntu | ruby-saml | 24.04 | 1.15.0-1ubuntu0.24.04.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-saml | source | bookworm | 1.13.0-1+deb12u1 | not yet assigned | Not reported | [1081560] |
| Ubuntu | ruby-saml | deb | noble | 1.15.0-1ubuntu0.24.04.1 | Not reported | Not reported | Not reported |
| Ubuntu | ruby-saml | deb | pro | 1.7.2-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2024-45409 | Not reported |
| Ubuntu | ruby-saml | deb | 20.04 | 1.11.0-1ubuntu0.1 | Not reported | UBUNTU-CVE-2024-45409 | Not reported |
| Ubuntu | ruby-saml | deb | 22.04 | 1.13.0-1ubuntu0.1 | Not reported | UBUNTU-CVE-2024-45409 | Not reported |
| Ubuntu | ruby-saml | deb | 24.04 | 1.15.0-1ubuntu0.24.04.1 | Not reported | UBUNTU-CVE-2024-45409 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ruby-saml]Fixed
Details (4)
1.13.0-1+deb12u1· all · bookwormFixed · Fixed:
1.13.0-1+deb12u1usn · ruby-saml · debian · bookworm; usn · ruby-saml · debian · 12
1.13.0-1+deb12u1· all · bookwormFixed · Fixed:
1.13.0-1+deb12u1usn · ruby-saml · debian · bookworm; usn · ruby-saml · debian · 12
1.13.0-1+deb12u1· all · bookworm-securityFixed · Fixed:
1.13.0-1+deb12u1usn · ruby-saml · debian · bookworm; usn · ruby-saml · debian · 12
1.13.0-1+deb12u1· all · bookworm-securityFixed · Fixed:
1.13.0-1+deb12u1usn · ruby-saml · debian · bookworm; usn · ruby-saml · debian · 12
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2024-45409]
- [https://osv.dev/vulnerability/DLA-3949-1]
- [https://osv.dev/vulnerability/DSA-5774-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2024-45409]
- [https://security-tracker.debian.org/tracker/CVE-2024-45409]
- [https://ubuntu.com/security/notices/USN-7309-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2024/wid-sec-w-2024-2162.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Ubuntu Security Notices (USN)]