
CVE catalog
CVE-2024-45598
cacti: CVE-2024-45598
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 3.05% · Oct 25, 2026
Cacti is an open source performance and fault management framework. Prior to 1.2.29, an administrator can change the `Poller Standard Error Log Path` parameter in either Installation Step 5 or in Configuration->Settings->Paths tab to a local file inside the server. Then simply going to Logs tab and selecting the name of the local file will show its content on the web UI. This vulnerability is fixed in 1.2.29.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | cacti | sid | 1.2.31+ds1-4 | fixed |
| Debian | cacti | forky | 1.2.31+ds1-4 | fixed |
| Debian | cacti | trixie | 1.2.30+ds1-1 | fixed |
| Debian | cacti | bookworm | 1.2.24+ds1-1+deb12u5 | fixed |
| Debian | cacti | bookworm-security | 1.2.24+ds1-1+deb12u5 | fixed |
| Ubuntu | cacti | pro | 1.2.16+ds1-2ubuntu1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1+esm1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1+esm1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1+esm2 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.25+ds1-2 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.26+ds1-1 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.26+ds1-1ubuntu0.1 | vulnerable |
| Ubuntu | cacti | 25.10 | 1.2.28+ds1-4ubuntu1 | vulnerable |
| Ubuntu | cacti | 25.10 | 1.2.30+ds1-1ubuntu1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | cacti | source | sid | 1.2.28+ds1-4 | not yet assigned | Not reported | [1094574] |
| Debian | cacti | source | forky | 1.2.28+ds1-4 | not yet assigned | Not reported | [1094574] |
| Debian | cacti | source | trixie | 1.2.28+ds1-4 | not yet assigned | Not reported | [1094574] |
| Debian | cacti | source | bookworm | 1.2.24+ds1-1+deb12u5 | not yet assigned | Not reported | [1094574] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [cacti]Fixed
Details (4)
1.2.24+ds1-1+deb12u5· all · bookwormFixed · Fixed:
1.2.24+ds1-1+deb12u5dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookwormFixed · Fixed:
1.2.24+ds1-1+deb12u5dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookworm-securityFixed · Fixed:
1.2.24+ds1-1+deb12u5dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookworm-securityFixed · Fixed:
1.2.24+ds1-1+deb12u5dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
[Debian 13 (Trixie)]
- [cacti]Fixed
Details (2)
1.2.30+ds1-1· all · trixieFixed · Fixed:
1.2.28+ds1-4dsa · cacti · debian · 13
1.2.30+ds1-1· all · trixieFixed · Fixed:
1.2.28+ds1-4dsa · cacti · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2024-45598]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2024-45598]
- [https://security-tracker.debian.org/tracker/CVE-2024-45598]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-0190.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database]