CVE catalog

CVE-2024-58250

ppp: CVE-2024-58250

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.24% · Oct 25, 2026

The passprompt plugin in pppd in ppp before 2.5.2 mishandles privileges.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpppsid2.5.2-1+2fixed
Debianpppforky2.5.2-1+2fixed
Debianppptrixie2.5.2-1+1fixed
Debianpppbookworm2.4.9-1+1.1vulnerable
Ubuntuppppro2.4.5-5.1ubuntu2vulnerable
Ubuntuppppro2.4.5-5.1ubuntu2.1vulnerable
Ubuntuppppro2.4.5-5.1ubuntu2.2vulnerable
Ubuntuppppro2.4.5-5.1ubuntu2.3vulnerable
Ubuntuppppro2.4.5-5.1ubuntu2.3+esm1vulnerable
Ubuntuppppro2.4.5-5.1ubuntu2.3+esm2vulnerable
Ubuntuppp16.042.4.6-3.1ubuntu1vulnerable
Ubuntuppp16.042.4.7-1+1ubuntu1vulnerable
Ubuntuppp16.042.4.7-1+2ubuntu1vulnerable
Ubuntuppp16.042.4.7-1+2ubuntu1.16.04.1vulnerable
Ubuntuppp16.042.4.7-1+2ubuntu1.16.04.2vulnerable
Ubuntuppp16.042.4.7-1+2ubuntu1.16.04.3vulnerable
Ubuntuppp18.042.4.7-1+2ubuntu1vulnerable
Ubuntuppp18.042.4.7-1+4ubuntu1vulnerable
Ubuntuppp18.042.4.7-1+4ubuntu3vulnerable
Ubuntuppp18.042.4.7-2+1ubuntu1vulnerable
Ubuntuppp18.042.4.7-2+2ubuntu1vulnerable
Ubuntuppp18.042.4.7-2+2ubuntu1.1vulnerable
Ubuntuppp18.042.4.7-2+2ubuntu1.2vulnerable
Ubuntuppp18.042.4.7-2+2ubuntu1.3vulnerable
Ubuntuppp20.042.4.7-2+4.1ubuntu4vulnerable
Ubuntuppp20.042.4.7-2+4.1ubuntu5vulnerable
Ubuntuppp20.042.4.7-2+4.1ubuntu5.1vulnerable
Ubuntuppp22.042.4.9-1+1ubuntu1vulnerable
Ubuntuppp22.042.4.9-1+1ubuntu2vulnerable
Ubuntuppp22.042.4.9-1+1ubuntu3vulnerable
Ubuntuppp24.042.4.9-1+1.1ubuntu1vulnerable
Ubuntuppp24.042.4.9-1+1.1ubuntu2vulnerable
Ubuntuppp24.042.4.9-1+1.1ubuntu4vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpppsourcesid2.5.2-1+1not yet assignedNot reportedNot reported
Debianpppsourceforky2.5.2-1+1not yet assignedNot reportedNot reported
Debianpppsourcetrixie2.5.2-1+1not yet assignedNot reportedNot reported
Debianpppsourcebookworm(unfixed)not yet assignedNot reportedNot reported

Notes

[bookworm] ppp: plugin removal may break existing configurations

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ppp]Affected

    Source package: [ppp]

    Details (2)
    • 2.4.9-1+1.1+b1 · amd64 · bookworm

      Affected

      dsa · ppp · debian · bookworm; dsa · ppp · debian · 12

    • 2.4.9-1+1.1+b1 · arm64 · bookworm

      Affected

      dsa · ppp · debian · bookworm; dsa · ppp · debian · 12

  • [ppp-dev]Affected

    Source package: [ppp]

    Details (2)
    • 2.4.9-1+1.1 · all · bookworm

      Affected

      dsa · ppp · debian · bookworm; dsa · ppp · debian · 12

    • 2.4.9-1+1.1 · all · bookworm

      Affected

      dsa · ppp · debian · bookworm; dsa · ppp · debian · 12

[Debian 13 (Trixie)]

  • [ppp]Fixed
    Details (2)
    • 2.5.2-1+1 · amd64 · trixie

      Fixed · Fixed: 2.5.2-1+1

      dsa · ppp · debian · 13

    • 2.5.2-1+1 · arm64 · trixie

      Fixed · Fixed: 2.5.2-1+1

      dsa · ppp · debian · 13

  • [ppp-dev]Fixed

    Source package: [ppp]

    Details (2)
    • 2.5.2-1+1 · all · trixie

      Fixed · Fixed: 2.5.2-1+1

      dsa · ppp · debian · 13

    • 2.5.2-1+1 · all · trixie

      Fixed · Fixed: 2.5.2-1+1

      dsa · ppp · debian · 13

Observed:

References