CVE catalog

CVE-2025-12819

pgbouncer: CVE-2025-12819

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
0.36% · Oct 25, 2026

Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpgbouncersid1.26.1-1fixed
Debianpgbouncerforky1.26.1-1fixed
Debianpgbouncertrixie1.24.1-1+deb13u2fixed
Debianpgbouncerbookworm1.18.0-1+deb12u1fixed
CpepgbouncerNot reported1.25.1fixed
Ubuntupgbouncer16.041.5.5-1vulnerable
Ubuntupgbouncer16.041.6.1-1vulnerable
Ubuntupgbouncer16.041.7-1vulnerable
Ubuntupgbouncer18.041.7.2-3build1vulnerable
Ubuntupgbouncer18.041.7.2-65-g2b8e6cf-1vulnerable
Ubuntupgbouncer18.041.8.1-1vulnerable
Ubuntupgbouncer18.041.8.1-1build1vulnerable
Ubuntupgbouncer20.041.10.0-1vulnerable
Ubuntupgbouncer20.041.10.0-1build1vulnerable
Ubuntupgbouncer20.041.11.0-1vulnerable
Ubuntupgbouncer20.041.12.0-2vulnerable
Ubuntupgbouncer20.041.12.0-3vulnerable
Ubuntupgbouncer22.041.15.0-1vulnerable
Ubuntupgbouncer22.041.16.1-1ubuntu1vulnerable
Ubuntupgbouncer24.041.20.0-1vulnerable
Ubuntupgbouncer24.041.21.0-1vulnerable
Ubuntupgbouncer24.041.22.0-1vulnerable
Ubuntupgbouncer24.041.22.0-1build1vulnerable
Ubuntupgbouncer24.041.22.0-1build3vulnerable
Ubuntupgbouncer24.041.22.0-1build4vulnerable
Ubuntupgbouncer25.101.24.0-3vulnerable
Ubuntupgbouncer25.101.24.1-1vulnerable
Ubuntupgbouncer26.041.24.1-1vulnerable
Ubuntupgbouncer26.041.25.0-2vulnerable
Ubuntupgbouncer26.041.25.1-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpgbouncersourcesid1.25.1-1not yet assignedNot reportedNot reported
Debianpgbouncersourceforky1.25.1-1not yet assignedNot reportedNot reported
Debianpgbouncersourcetrixie1.24.1-1+deb13u1not yet assignedNot reportedNot reported
Debianpgbouncersourcebookworm1.18.0-1+deb12u1not yet assignedNot reportedNot reported
CpepgbouncercpeNot reported1.25.1Not reportedNVD-CVE-2025-12819Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [pgbouncer]Fixed
    Details (2)
    • 1.18.0-1+deb12u1 · amd64 · bookworm

      Fixed · Fixed: 1.18.0-1+deb12u1

      dsa · pgbouncer · debian · bookworm; dsa · pgbouncer · debian · 12

    • 1.18.0-1+deb12u1 · arm64 · bookworm

      Fixed · Fixed: 1.18.0-1+deb12u1

      dsa · pgbouncer · debian · bookworm; dsa · pgbouncer · debian · 12

[Debian 13 (Trixie)]

  • [pgbouncer]Fixed
    Details (2)
    • 1.24.1-1+deb13u2 · amd64 · trixie

      Fixed · Fixed: 1.24.1-1+deb13u1

      dsa · pgbouncer · debian · 13

    • 1.24.1-1+deb13u2 · arm64 · trixie

      Fixed · Fixed: 1.24.1-1+deb13u1

      dsa · pgbouncer · debian · 13

Observed:

References