
CVE catalog
CVE-2025-15569
UBUNTU-CVE-2025-15569
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.13% · Oct 25, 2026
A flaw has been found in Artifex MuPDF up to 1.26.1 on Windows. The impacted element is the function get_system_dpi of the file platform/x11/win_main.c. This manipulation causes uncontrolled search path. The attack requires local access. The attack is considered to have high complexity. The exploitability is regarded as difficult. Upgrading to version 1.26.2 is sufficient to resolve this issue. Patch name: ebb125334eb007d64e579204af3c264aadf2e244. Upgrading the affected component is recommended.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | mupdf | pro | 1.7-1 | vulnerable |
| Ubuntu | mupdf | pro | 1.7a-1 | vulnerable |
| Ubuntu | mupdf | pro | 1.7a-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | mupdf | pro | 1.11+ds1-1.1 | vulnerable |
| Ubuntu | mupdf | pro | 1.11+ds1-2 | vulnerable |
| Ubuntu | mupdf | pro | 1.12.0+ds1-1 | vulnerable |
| Ubuntu | mupdf | pro | 1.12.0+ds1-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | mupdf | pro | 1.12.0+ds1-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | mupdf | pro | 1.15.0+ds1-1 | vulnerable |
| Ubuntu | mupdf | pro | 1.16.1+ds1-1ubuntu1 | vulnerable |
| Ubuntu | mupdf | pro | 1.16.1+ds1-1ubuntu1+esm1 | vulnerable |
| Ubuntu | mupdf | pro | 1.16.1+ds1-1ubuntu1+esm2 | vulnerable |
| Ubuntu | mupdf | 22.04 | 1.17.0+ds1-2 | vulnerable |
| Ubuntu | mupdf | 22.04 | 1.19.0+ds1-1 | vulnerable |
| Ubuntu | mupdf | 22.04 | 1.19.0+ds1-1build1 | vulnerable |
| Ubuntu | mupdf | 22.04 | 1.19.0+ds1-2 | vulnerable |
| Ubuntu | mupdf | 24.04 | 1.22.2+ds1-2 | vulnerable |
| Ubuntu | mupdf | 24.04 | 1.22.2+ds1-2build1 | vulnerable |
| Ubuntu | mupdf | 24.04 | 1.23.6+ds1-1 | vulnerable |
| Ubuntu | mupdf | 24.04 | 1.23.7+ds1-1 | vulnerable |
| Ubuntu | mupdf | 24.04 | 1.23.10+ds1-1 | vulnerable |
| Ubuntu | mupdf | 24.04 | 1.23.10+ds1-1build1 | vulnerable |
| Ubuntu | mupdf | 24.04 | 1.23.10+ds1-1build2 | vulnerable |
| Ubuntu | mupdf | 24.04 | 1.23.10+ds1-1build3 | vulnerable |
| Ubuntu | mupdf | 25.10 | 1.25.1+ds1-5build2 | vulnerable |
| Ubuntu | mupdf | 25.10 | 1.25.1+ds1-6 | vulnerable |
| Ubuntu | mupdf | 25.10 | 1.25.1+ds1-7 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: