
CVE catalog
CVE-2025-23217
mitmproxy: CVE-2025-23217
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.87% · Oct 25, 2026
mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb's proxy server (bound to `*:8080` by default) to access mitmweb's internal API (bound to `127.0.0.1:8081` by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | mitmproxy | sid | 8.1.1-4 | fixed |
| Debian | mitmproxy | forky | 8.1.1-4 | fixed |
| Debian | mitmproxy | bookworm | 8.1.1-2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | mitmproxy | source | sid | 8.1.1-4 | not yet assigned | Not reported | [1103701] |
| Debian | mitmproxy | source | forky | 8.1.1-4 | not yet assigned | Not reported | [1103701] |
| Debian | mitmproxy | source | bookworm | (unfixed) | not yet assigned | Not reported | [1103701] |
Notes
[bookworm] mitmproxy: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [mitmproxy]Affected
Details (2)
8.1.1-2· all · bookwormAffected
dsa · mitmproxy · debian · bookworm; dsa · mitmproxy · debian · 12
8.1.1-2· all · bookwormAffected
dsa · mitmproxy · debian · bookworm; dsa · mitmproxy · debian · 12
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2025_14762-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-23217]
- [https://security-tracker.debian.org/tracker/CVE-2025-23217]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [SUSE security advisories and VEX]