
CVE catalog
CVE-2025-24814
lucene-solr: CVE-2025-24814
- Severity
- Medium · CVSS 4.6
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.17% · Oct 27, 2026
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | lucene-solr | sid | 3.6.2+dfsg-28 | fixed |
| Debian | lucene-solr | forky | 3.6.2+dfsg-28 | fixed |
| Debian | lucene-solr | trixie | 3.6.2+dfsg-26 | fixed |
| Debian | lucene-solr | bookworm | 3.6.2+dfsg-26 | fixed |
| Ubuntu | lucene-solr | pro | 3.6.2+dfsg-10 | vulnerable |
| Ubuntu | lucene-solr | pro | 3.6.2+dfsg-11 | vulnerable |
| Ubuntu | lucene-solr | pro | 3.6.2+dfsg-18~18.04 | vulnerable |
| Ubuntu | lucene-solr | pro | 3.6.2+dfsg-18~18.04.1~esm2 | vulnerable |
| Ubuntu | lucene-solr | 20.04 | 3.6.2+dfsg-20 | vulnerable |
| Ubuntu | lucene-solr | 20.04 | 3.6.2+dfsg-22 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | lucene-solr | source | sid | 3.6.2+dfsg-23 | not yet assigned | Not reported | Not reported |
| Debian | lucene-solr | source | forky | 3.6.2+dfsg-23 | not yet assigned | Not reported | Not reported |
| Debian | lucene-solr | source | trixie | 3.6.2+dfsg-23 | not yet assigned | Not reported | Not reported |
| Debian | lucene-solr | source | bookworm | 3.6.2+dfsg-23 | not yet assigned | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [liblucene3-contrib-java]Fixed
Source package: [lucene-solr]
Details (2)
3.6.2+dfsg-26· all · bookwormFixed · Fixed:
3.6.2+dfsg-23dsa · lucene-solr · debian · bookworm; dsa · lucene-solr · debian · 12
3.6.2+dfsg-26· all · bookwormFixed · Fixed:
3.6.2+dfsg-23dsa · lucene-solr · debian · bookworm; dsa · lucene-solr · debian · 12
- [liblucene3-java]Fixed
Source package: [lucene-solr]
Details (2)
3.6.2+dfsg-26· all · bookwormFixed · Fixed:
3.6.2+dfsg-23dsa · lucene-solr · debian · bookworm; dsa · lucene-solr · debian · 12
3.6.2+dfsg-26· all · bookwormFixed · Fixed:
3.6.2+dfsg-23dsa · lucene-solr · debian · bookworm; dsa · lucene-solr · debian · 12
[Debian 13 (Trixie)]
- [liblucene3-contrib-java]Fixed
Source package: [lucene-solr]
Details (2)
3.6.2+dfsg-26· all · trixieFixed · Fixed:
3.6.2+dfsg-23dsa · lucene-solr · debian · 13
3.6.2+dfsg-26· all · trixieFixed · Fixed:
3.6.2+dfsg-23dsa · lucene-solr · debian · 13
- [liblucene3-java]Fixed
Source package: [lucene-solr]
Details (2)
3.6.2+dfsg-26· all · trixieFixed · Fixed:
3.6.2+dfsg-23dsa · lucene-solr · debian · 13
3.6.2+dfsg-26· all · trixieFixed · Fixed:
3.6.2+dfsg-23dsa · lucene-solr · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-24814]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-24814]
- [https://security-tracker.debian.org/tracker/CVE-2025-24814]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-24814.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1560.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]