CVE catalog

CVE-2025-2849

upx-5.0.0-2.1 on GA media

[CVE catalog]

Severity
Low · CVSS 3.3CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.30% · Oct 25, 2026

A vulnerability, which was classified as problematic, was found in UPX up to 5.0.0. Affected is the function PackLinuxElf64::un_DT_INIT of the file src/p_lx_elf.cpp. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. The patch is identified as e0b6ff192412f5bb5364c1948f4f6b27a0cd5ea2. It is recommended to apply a patch to fix this issue.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianupx-ucl134.2.4-1.1fixed
Debianupx-ucl144.2.4-1.1fixed
Opensuseupxtumbleweed5.0.0-2.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianupx-ucldeb134.2.4-1.1Not reportedDEBIAN-CVE-2025-2849Not reported
Debianupx-ucldeb144.2.4-1.1Not reportedDEBIAN-CVE-2025-2849Not reported
Opensuseupxrpmtumbleweed5.0.0-2.1Not reportedOPENSUSE-SU-2025:14947-1Not reported

OpenFactory catalog packages

[Debian 13 (Trixie)]

  • [upx-ucl]Fixed
    Details (2)
    • 4.2.4-1.1 · amd64 · trixie

      Fixed · Fixed: 4.2.4-1.1

      pypi · upx-ucl · debian · 13

    • 4.2.4-1.1 · arm64 · trixie

      Fixed · Fixed: 4.2.4-1.1

      pypi · upx-ucl · debian · 13

[openSUSE Tumbleweed]

  • [upx]Fixed

    Source package: [upx]

    Details (1)
    • 5.2.1-1.1 · x86_64 · tumbleweed

      Fixed · Fixed: 5.0.0-2.1

      pypi · upx · opensuse · tumbleweed

Observed:

References