
CVE catalog
CVE-2025-30215
nats-server: CVE-2025-30215
- Severity
- Critical · CVSS 9.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.60% · Oct 25, 2026
NATS-Server is a High-Performance server for NATS.io, the cloud and edge native messaging system. In versions starting from 2.2.0 but prior to 2.10.27 and 2.11.1, the management of JetStream assets happens with messages in the $JS. subject namespace in the system account; this is partially exposed into regular accounts to allow account holders to manage their assets. Some of the JS API requests were missing access controls, allowing any user with JS management permissions in any account to perform certain administrative actions on any JS asset in any other account. At least one of the unprotected APIs allows for data destruction. None of the affected APIs allow disclosing stream contents. This vulnerability is fixed in v2.11.1 or v2.10.27.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | nats-server | sid | 2.15.1-1 | fixed |
| Debian | nats-server | forky | 2.15.1-1 | fixed |
| Debian | nats-server | trixie | 2.10.27-1 | fixed |
| Debian | nats-server | bookworm | 2.9.10-1 | vulnerable |
| Opensuse | govulncheck-vulndb | tumbleweed | 0.0.20250422T152923-1.1 | fixed |
| Ubuntu | nats-server | 24.04 | 2.9.19-1build1 | vulnerable |
| Ubuntu | nats-server | 24.04 | 2.10.3-1 | vulnerable |
| Ubuntu | nats-server | 24.04 | 2.10.4-1 | vulnerable |
| Ubuntu | nats-server | 24.04 | 2.10.7-1 | vulnerable |
| Ubuntu | nats-server | 24.04 | 2.10.7-1ubuntu0.1 | vulnerable |
| Ubuntu | nats-server | 24.04 | 2.10.7-1ubuntu0.2 | vulnerable |
| Ubuntu | nats-server | 24.04 | 2.10.7-1ubuntu0.3 | vulnerable |
| Ubuntu | nats-server | 25.10 | 2.10.24-1 | vulnerable |
| Ubuntu | nats-server | 25.10 | 2.10.27-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | nats-server | source | sid | 2.10.27-1 | not yet assigned | Not reported | Not reported |
| Debian | nats-server | source | forky | 2.10.27-1 | not yet assigned | Not reported | Not reported |
| Debian | nats-server | source | trixie | 2.10.27-1 | not yet assigned | Not reported | Not reported |
| Debian | nats-server | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Opensuse | govulncheck-vulndb | rpm | tumbleweed | 0.0.20250422T152923-1.1 | Not reported | OPENSUSE-SU-2025:15014-1 | Not reported |
Notes
[bookworm] nats-server: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [golang-github-nats-io-nats-server-dev]Affected
Source package: [nats-server]
Details (2)
2.9.10-1· all · bookwormAffected
dsa · nats-server · debian · bookworm; dsa · nats-server · debian · 12
2.9.10-1· all · bookwormAffected
dsa · nats-server · debian · bookworm; dsa · nats-server · debian · 12
- [nats-server]Affected
Source package: [nats-server]
Details (2)
2.9.10-1+b3· amd64 · bookwormAffected
dsa · nats-server · debian · bookworm; dsa · nats-server · debian · 12
2.9.10-1+b3· arm64 · bookwormAffected
dsa · nats-server · debian · bookworm; dsa · nats-server · debian · 12
[Debian 13 (Trixie)]
Source package: [nats-server]
Details (2)
2.10.27-1· all · trixieFixed · Fixed:
2.10.27-1dsa · nats-server · debian · 13
2.10.27-1· all · trixieFixed · Fixed:
2.10.27-1dsa · nats-server · debian · 13
- [nats-server]Fixed
Source package: [nats-server]
Details (2)
2.10.27-1+b2· amd64 · trixieFixed · Fixed:
2.10.27-1dsa · nats-server · debian · 13
2.10.27-1+b2· arm64 · trixieFixed · Fixed:
2.10.27-1dsa · nats-server · debian · 13
[openSUSE Tumbleweed]
- [govulncheck-vulndb]Fixed
Source package: [govulncheck-vulndb]
Details (1)
0.0.20260828T144745-1.1· noarch · tumbleweedFixed · Fixed:
0.0.20250422T152923-1.1dsa · govulncheck-vulndb · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2025_15014-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-30215]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-30215]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:15014-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-30215]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-30215.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-0782.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]