
CVE catalog
CVE-2025-31672
libapache-poi-java: CVE-2025-31672
- Severity
- Medium · CVSS 4.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.35% · Oct 25, 2026
Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libapache-poi-java | sid | 4.1.1-1 | vulnerable |
| Debian | libapache-poi-java | forky | 4.1.1-1 | vulnerable |
| Debian | libapache-poi-java | trixie | 4.0.1-6 | vulnerable |
| Debian | libapache-poi-java | bookworm | 4.0.1-4 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libapache-poi-java | source | sid | (unfixed) | not yet assigned | Not reported | [1103629] |
| Debian | libapache-poi-java | source | forky | (unfixed) | not yet assigned | Not reported | [1103629] |
| Debian | libapache-poi-java | source | trixie | (unfixed) | not yet assigned | Not reported | [1103629] |
| Debian | libapache-poi-java | source | bookworm | (unfixed) | not yet assigned | Not reported | [1103629] |
Notes
[trixie] libapache-poi-java: Minor issue [bookworm] libapache-poi-java: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libapache-poi-java]Affected
Details (2)
4.0.1-4· all · bookwormAffected
dsa · libapache-poi-java · debian · bookworm; dsa · libapache-poi-java · debian · 12
4.0.1-4· all · bookwormAffected
dsa · libapache-poi-java · debian · bookworm; dsa · libapache-poi-java · debian · 12
- [libapache-poi-java-doc]Affected
Source package: [libapache-poi-java]
Details (2)
4.0.1-4· all · bookwormAffected
dsa · libapache-poi-java · debian · bookworm; dsa · libapache-poi-java · debian · 12
4.0.1-4· all · bookwormAffected
dsa · libapache-poi-java · debian · bookworm; dsa · libapache-poi-java · debian · 12
[Debian 13 (Trixie)]
- [libapache-poi-java]Affected
Details (2)
4.0.1-6· all · trixieAffected
dsa · libapache-poi-java · debian · 13
4.0.1-6· all · trixieAffected
dsa · libapache-poi-java · debian · 13
- [libapache-poi-java-doc]Affected
Source package: [libapache-poi-java]
Details (2)
4.0.1-6· all · trixieAffected
dsa · libapache-poi-java · debian · 13
4.0.1-6· all · trixieAffected
dsa · libapache-poi-java · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-31672]
- [https://security-tracker.debian.org/tracker/CVE-2025-31672]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-31672.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-0871.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]