CVE catalog

CVE-2025-40907

libfcgi-perl: CVE-2025-40907

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
0.68% · Oct 25, 2026

FCGI versions 0.44 through 0.82, for Perl, include a vulnerable version of the FastCGI fcgi2 (aka fcgi) library. The included FastCGI library is affected by CVE-2025-23016, causing an integer overflow (and resultant heap-based buffer overflow) via crafted nameLen or valueLen values in data to the IPC socket. This occurs in ReadParams in fcgiapp.c.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibfcgi-perlsid0.82+ds-3fixed
Debianlibfcgi-perlforky0.82+ds-3fixed
Debianlibfcgi-perltrixie0.82+ds-3fixed
Debianlibfcgi-perlbookworm0.82+ds-2fixed
Ubuntulibfcgi-perlpro0.78-2build1vulnerable
Ubuntulibfcgi-perlpro0.78-2ubuntu0.1~esm1fixed
Ubuntulibfcgi-perl20.040.78-2build2vulnerable
Ubuntulibfcgi-perl20.040.78-2build3vulnerable
Ubuntulibfcgi-perl20.040.79-1vulnerable
Ubuntulibfcgi-perl20.040.79-1ubuntu0.1fixed
Ubuntulibfcgi-perlpro0.78-2build1vulnerable
Ubuntulibfcgi-perlpro0.78-2ubuntu0.1~esm1fixed
Ubuntulibfcgi-perl20.040.78-2build2vulnerable
Ubuntulibfcgi-perl20.040.78-2build3vulnerable
Ubuntulibfcgi-perl20.040.79-1vulnerable
Ubuntulibfcgi-perl20.040.79-1ubuntu0.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibfcgi-perlsourcesid0.79+ds-2not yet assignedNot reportedNot reported
Debianlibfcgi-perlsourceforky0.79+ds-2not yet assignedNot reportedNot reported
Debianlibfcgi-perlsourcetrixie0.79+ds-2not yet assignedNot reportedNot reported
Debianlibfcgi-perlsourcebookworm0.79+ds-2not yet assignedNot reportedNot reported
Ubuntulibfcgi-perldebpro0.78-2ubuntu0.1~esm1Not reportedUSN-7527-1Not reported
Ubuntulibfcgi-perldeb20.040.79-1ubuntu0.1Not reportedUSN-7527-1Not reported
Ubuntulibfcgi-perldebpro0.78-2ubuntu0.1~esm1Not reportedUBUNTU-CVE-2025-40907Not reported
Ubuntulibfcgi-perldeb20.040.79-1ubuntu0.1Not reportedUBUNTU-CVE-2025-40907Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 0.82+ds-2 · amd64 · bookworm

      Fixed · Fixed: 0.79+ds-2

      dsa · libfcgi-perl · debian · bookworm; dsa · libfcgi-perl · debian · 12

    • 0.82+ds-2 · arm64 · bookworm

      Fixed · Fixed: 0.79+ds-2

      dsa · libfcgi-perl · debian · bookworm; dsa · libfcgi-perl · debian · 12

[Debian 13 (Trixie)]

  • Source package: [libfcgi-perl]

    Details (2)
    • 0.82+ds-3+b2 · amd64 · trixie

      Fixed · Fixed: 0.79+ds-2

      dsa · libfcgi-perl · debian · 13

    • 0.82+ds-3+b2 · arm64 · trixie

      Fixed · Fixed: 0.79+ds-2

      dsa · libfcgi-perl · debian · 13

Observed:

References