CVE catalog

CVE-2025-40927

libcgi-simple-perl: CVE-2025-40927

[CVE catalog]

Severity
High · CVSS 7.3CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Published
Source
[NVD] · [CVE record]
EPSS
0.47% · Oct 25, 2026

CGI::Simple versions before 1.282 for Perl has a HTTP response splitting flaw This vulnerability is a confirmed HTTP response splitting flaw in CGI::Simple that allows HTTP response header injection, which can be used for reflected XSS or open redirect under certain conditions. Although some validation exists, it can be bypassed using URL-encoded values, allowing an attacker to inject untrusted content into the response via query parameters. As a result, an attacker can inject a line break (e.g. %0A) into the parameter value, causing the server to split the HTTP response and inject arbitrary headers or even an HTML/JavaScript body, leading to reflected cross-site scripting (XSS), open redirect or other attacks. The issue documented in CVE-2010-4410 https://www.cve.org/CVERecord?id=CVE-2010-4410 is related but the fix was incomplete. Impact By injecting %0A (newline) into a query string parameter, an attacker can: * Break the current HTTP header * Inject a new header or entire body * Deliver a script payload that is reflected in the server’s response That can lead to the following attacks: * reflected XSS * open redirect * cache poisoning * header manipulation

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibcgi-simple-perlsid1.282-1fixed
Debianlibcgi-simple-perlforky1.282-1fixed
Debianlibcgi-simple-perltrixie1.282-1~deb13u1fixed
Debianlibcgi-simple-perlbookworm1.280-2+deb12u1fixed
Ubuntulibcgi-simple-perl16.041.115-1vulnerable
Ubuntulibcgi-simple-perl16.041.115-2vulnerable
Ubuntulibcgi-simple-perl18.041.115-2vulnerable
Ubuntulibcgi-simple-perl20.041.115-2vulnerable
Ubuntulibcgi-simple-perl22.041.115-2vulnerable
Ubuntulibcgi-simple-perl22.041.280-1vulnerable
Ubuntulibcgi-simple-perl24.041.280-2vulnerable
Ubuntulibcgi-simple-perl24.041.281-1vulnerable
Ubuntulibcgi-simple-perl25.101.281-1vulnerable
Ubuntulibcgi-simple-perl26.041.281-1vulnerable
Ubuntulibcgi-simple-perl26.041.282-1vulnerable
Opensuseperl-CGI-Simpletumbleweed1.282.0-1.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibcgi-simple-perlsourcesid1.282-1not yet assignedNot reportedNot reported
Debianlibcgi-simple-perlsourceforky1.282-1not yet assignedNot reportedNot reported
Debianlibcgi-simple-perlsourcetrixie1.282-1~deb13u1not yet assignedNot reportedNot reported
Debianlibcgi-simple-perlsourcebookworm1.280-2+deb12u1not yet assignedNot reportedNot reported
Opensuseperl-CGI-Simplerpmtumbleweed1.282.0-1.1Not reportedOPENSUSE-SU-2025:15625-1Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.280-2+deb12u1 · all · bookworm

      Fixed · Fixed: 1.280-2+deb12u1

      dsa · libcgi-simple-perl · debian · bookworm; dsa · libcgi-simple-perl · debian · 12

    • 1.280-2+deb12u1 · all · bookworm

      Fixed · Fixed: 1.280-2+deb12u1

      dsa · libcgi-simple-perl · debian · bookworm; dsa · libcgi-simple-perl · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1.282-1~deb13u1 · all · trixie

      Fixed · Fixed: 1.282-1~deb13u1

      dsa · libcgi-simple-perl · debian · 13

    • 1.282-1~deb13u1 · all · trixie

      Fixed · Fixed: 1.282-1~deb13u1

      dsa · libcgi-simple-perl · debian · 13

[openSUSE Tumbleweed]

  • Source package: [perl-CGI-Simple]

    Details (1)
    • 1.282.0-1.4 · noarch · tumbleweed

      Fixed · Fixed: 1.282.0-1.1

      dsa · perl-CGI-Simple · opensuse · tumbleweed

Observed:

References