
CVE catalog
CVE-2025-46337
libphp-adodb: CVE-2025-46337
- Severity
- Critical · CVSS 10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.74% · Oct 25, 2026
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libphp-adodb | sid | 5.22.12-1 | fixed |
| Debian | libphp-adodb | forky | 5.22.12-1 | fixed |
| Debian | libphp-adodb | trixie | 5.22.9-0.1+deb13u1 | fixed |
| Debian | libphp-adodb | bookworm | 5.21.4-1+deb12u2 | fixed |
| Ubuntu | libphp-adodb | pro | 5.21.4-1 | vulnerable |
| Ubuntu | libphp-adodb | pro | 5.21.4-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | libphp-adodb | 25.10 | 5.22.8-0.1 | vulnerable |
| Ubuntu | libphp-adodb | 25.10 | 5.22.9-0.1 | fixed |
| Ubuntu | libphp-adodb | 26.04 | 5.22.9-0.1 | fixed |
| Ubuntu | libphp-adodb | 25.04 | 5.22.7-0.1 | vulnerable |
| Ubuntu | libphp-adodb | 25.04 | 5.22.8-0.1 | vulnerable |
| Ubuntu | libphp-adodb | 25.04 | 5.22.8-0.1ubuntu0.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libphp-adodb | source | sid | 5.22.9-0.1 | not yet assigned | Not reported | [1104548] |
| Debian | libphp-adodb | source | forky | 5.22.9-0.1 | not yet assigned | Not reported | [1104548] |
| Debian | libphp-adodb | source | trixie | 5.22.9-0.1 | not yet assigned | Not reported | [1104548] |
| Debian | libphp-adodb | source | bookworm | 5.21.4-1+deb12u1 | not yet assigned | Not reported | [1104548] |
| Ubuntu | libphp-adodb | deb | 25.10 | 5.22.9-0.1 | Not reported | UBUNTU-CVE-2025-46337 | Not reported |
| Ubuntu | libphp-adodb | deb | 26.04 | 5.22.9-0.1 | Not reported | UBUNTU-CVE-2025-46337 | Not reported |
| Ubuntu | libphp-adodb | deb | 25.04 | 5.22.8-0.1ubuntu0.1 | Not reported | USN-7530-1 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libphp-adodb]Fixed
Details (4)
5.21.4-1+deb12u2· all · bookwormFixed · Fixed:
5.21.4-1+deb12u1dsa · libphp-adodb · debian · bookworm; dsa · libphp-adodb · debian · 12
5.21.4-1+deb12u2· all · bookwormFixed · Fixed:
5.21.4-1+deb12u1dsa · libphp-adodb · debian · bookworm; dsa · libphp-adodb · debian · 12
5.22.9-0.1~bpo12+1· all · bookworm-backportsFixed · Fixed:
5.21.4-1+deb12u1dsa · libphp-adodb · debian · bookworm; dsa · libphp-adodb · debian · 12
5.22.9-0.1~bpo12+1· all · bookworm-backportsFixed · Fixed:
5.21.4-1+deb12u1dsa · libphp-adodb · debian · bookworm; dsa · libphp-adodb · debian · 12
[Debian 13 (Trixie)]
- [libphp-adodb]Fixed
Details (2)
5.22.9-0.1+deb13u1· all · trixieFixed · Fixed:
5.22.9-0.1dsa · libphp-adodb · debian · 13
5.22.9-0.1+deb13u1· all · trixieFixed · Fixed:
5.22.9-0.1dsa · libphp-adodb · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-46337]
- [https://osv.dev/vulnerability/DLA-4177-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-46337]
- [https://osv.dev/vulnerability/USN-7530-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-46337]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-46337.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1353.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]