
CVE catalog
CVE-2025-47291
containerd: CVE-2025-47291
- Severity
- Medium · CVSS 6.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.29% · Oct 25, 2026
containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | containerd | sid | 2.1.9+ds1-5 | not affected |
| Debian | containerd | forky | 2.1.9+ds1-5 | not affected |
| Debian | containerd | trixie | 1.7.24~ds1-6+deb13u1 | not affected |
| Debian | containerd | trixie-security | 1.7.24~ds1-6+deb13u1 | not affected |
| Debian | containerd | bookworm | 1.6.20~ds1-1+deb12u3 | not affected |
| Debian | containerd | bookworm-security | 1.6.20~ds1-1+deb12u2 | not affected |
| Ubuntu | containerd-app | 25.10 | 2.0.2-0ubuntu2 | vulnerable |
| Ubuntu | containerd-app | 25.10 | 2.0.5-0ubuntu1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | containerd | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | containerd | source | forky | Not affected | unimportant | Not reported | Not reported |
| Debian | containerd | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | containerd | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Ubuntu | containerd-app | deb | 25.10 | 2.0.5-0ubuntu1 | Not reported | UBUNTU-CVE-2025-47291 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [containerd]Not affected
Details (4)
1.6.20~ds1-1+deb12u3· amd64 · bookwormNot affected
dsa · containerd · debian · bookworm
1.6.20~ds1-1+deb12u3· arm64 · bookwormNot affected
dsa · containerd · debian · bookworm
1.6.20~ds1-1+deb12u2· amd64 · bookworm-securityNot affected
dsa · containerd · debian · bookworm
1.6.20~ds1-1+deb12u2· arm64 · bookworm-securityNot affected
dsa · containerd · debian · bookworm
- [golang-github-containerd-containerd-dev]Not affected
Source package: [containerd]
Details (4)
1.6.20~ds1-1+deb12u3· all · bookwormNot affected
dsa · containerd · debian · bookworm
1.6.20~ds1-1+deb12u3· all · bookwormNot affected
dsa · containerd · debian · bookworm
1.6.20~ds1-1+deb12u2· all · bookworm-securityNot affected
dsa · containerd · debian · bookworm
1.6.20~ds1-1+deb12u2· all · bookworm-securityNot affected
dsa · containerd · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2025_15159-1.json]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-47291]
- [https://security-tracker.debian.org/tracker/CVE-2025-47291]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-47291.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]