CVE catalog

CVE-2025-48866

ModSecurity vulnerabilities

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
0.83% · Oct 25, 2026

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Versions prior to 2.9.10 contain a denial of service vulnerability similar to GHSA-859r-vvv8-rm8r/CVE-2025-47947. The `sanitiseArg` (and `sanitizeArg` - this is the same action but an alias) is vulnerable to adding an excessive number of arguments, thereby leading to denial of service. Version 2.9.10 fixes the issue. As a workaround, avoid using rules that contain the `sanitiseArg` (or `sanitizeArg`) action.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianmodsecurity-apachesid2.9.13-1fixed
Debianmodsecurity-apacheforky2.9.13-1fixed
Debianmodsecurity-apachetrixie2.9.11-1+deb13u1fixed
Debianmodsecurity-apachebookworm2.9.7-1+deb12u2fixed
Debianmodsecurity-apachebookworm-security2.9.7-1+deb12u1fixed
Ubuntumodsecurity-apachenoble2.9.7-1ubuntu0.24.04.1~esm1fixed
Ubuntulibapache2-mod-security2noble2.9.7-1ubuntu0.24.04.1~esm1fixed
Ubuntumodsecurity-apachepro2.9.7-1vulnerable
Ubuntumodsecurity-apachepro2.9.7-1build2vulnerable
Ubuntumodsecurity-apachepro2.9.7-1build3vulnerable
Ubuntumodsecurity-apachepro2.9.7-1ubuntu0.24.04.1~esm1fixed
Ubuntumodsecurity-apache25.102.9.8-1.1vulnerable
Ubuntumodsecurity-apache25.102.9.9-1vulnerable
Ubuntumodsecurity-apache25.102.9.9-1ubuntu1vulnerable
Ubuntumodsecurity-apache25.102.9.12-2vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianmodsecurity-apachesourcesid2.9.10-1not yet assignedNot reported[1107196]
Debianmodsecurity-apachesourceforky2.9.10-1not yet assignedNot reported[1107196]
Debianmodsecurity-apachesourcetrixie2.9.10-1not yet assignedNot reported[1107196]
Debianmodsecurity-apachesourcebookworm2.9.7-1+deb12u1not yet assignedNot reported[1107196]
Ubuntumodsecurity-apachedebnoble2.9.7-1ubuntu0.24.04.1~esm1Not reportedNot reportedNot reported
Ubuntulibapache2-mod-security2debnoble2.9.7-1ubuntu0.24.04.1~esm1Not reportedNot reportedNot reported
Ubuntumodsecurity-apachedebpro2.9.7-1ubuntu0.24.04.1~esm1Not reportedUBUNTU-CVE-2025-48866Not reported

[Debian bug #1107196]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [modsecurity-apache]

    Details (4)
    • 2.9.7-1+deb12u2 · amd64 · bookworm

      Fixed · Fixed: 2.9.7-1+deb12u1

      usn · modsecurity-apache · debian · bookworm; usn · modsecurity-apache · debian · 12

    • 2.9.7-1+deb12u2 · arm64 · bookworm

      Fixed · Fixed: 2.9.7-1+deb12u1

      usn · modsecurity-apache · debian · bookworm; usn · modsecurity-apache · debian · 12

    • 2.9.7-1+deb12u1 · amd64 · bookworm-security

      Fixed · Fixed: 2.9.7-1+deb12u1

      usn · modsecurity-apache · debian · bookworm; usn · modsecurity-apache · debian · 12

    • 2.9.7-1+deb12u1 · arm64 · bookworm-security

      Fixed · Fixed: 2.9.7-1+deb12u1

      usn · modsecurity-apache · debian · bookworm; usn · modsecurity-apache · debian · 12

[Debian 13 (Trixie)]

  • Source package: [modsecurity-apache]

    Details (2)
    • 2.9.11-1+deb13u1 · amd64 · trixie

      Fixed · Fixed: 2.9.10-1

      usn · modsecurity-apache · debian · 13

    • 2.9.11-1+deb13u1 · arm64 · trixie

      Fixed · Fixed: 2.9.10-1

      usn · modsecurity-apache · debian · 13

Observed:

References