
CVE catalog
CVE-2025-49128
jackson-core: CVE-2025-49128
- Severity
- Medium · CVSS 4
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.39% · Oct 27, 2026
Jackson-core contains core low-level incremental ("streaming") parser and generator abstractions used by Jackson Data Processor. Starting in version 2.0.0 and prior to version 2.13.0, a flaw in jackson-core's `JsonLocation._appendSourceDesc` method allows up to 500 bytes of unintended memory content to be included in exception messages. When parsing JSON from a byte array with an offset and length, the exception message incorrectly reads from the beginning of the array instead of the logical payload start. This results in possible information disclosure in systems using pooled or reused buffers, like Netty or Vert.x. This issue was silently fixed in jackson-core version 2.13.0, released on September 30, 2021, via PR #652. All users should upgrade to version 2.13.0 or later. If upgrading is not immediately possible, applications can mitigate the issue by disabling exception message exposure to clients to avoid returning parsing exception messages in HTTP responses and/or disabling source inclusion in exceptions to prevent Jackson from embedding any source content in exception messages, avoiding leakage.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jackson-core | sid | 2.22.4-1 | fixed |
| Debian | jackson-core | forky | 2.22.4-1 | fixed |
| Debian | jackson-core | trixie | 2.14.1-2~deb13u1 | fixed |
| Debian | jackson-core | trixie-security | 2.14.1-2~deb13u1 | fixed |
| Debian | jackson-core | bookworm | 2.14.1-2~deb12u1 | fixed |
| Debian | jackson-core | bookworm-security | 2.14.1-2~deb12u1 | fixed |
| Ubuntu | jackson-core | 16.04 | 2.4.2-2 | vulnerable |
| Ubuntu | jackson-core | 18.04 | 2.8.6-1 | vulnerable |
| Ubuntu | jackson-core | 18.04 | 2.9.1-1 | vulnerable |
| Ubuntu | jackson-core | 18.04 | 2.9.4-1 | vulnerable |
| Ubuntu | jackson-core | 18.04 | 2.9.8-3~18.04 | vulnerable |
| Ubuntu | jackson-core | 20.04 | 2.9.8-3 | vulnerable |
| Ubuntu | jackson-core | 20.04 | 2.10.0-1 | vulnerable |
| Ubuntu | jackson-core | 20.04 | 2.10.1-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jackson-core | source | sid | 2.13.0-1 | not yet assigned | Not reported | Not reported |
| Debian | jackson-core | source | forky | 2.13.0-1 | not yet assigned | Not reported | Not reported |
| Debian | jackson-core | source | trixie | 2.13.0-1 | not yet assigned | Not reported | Not reported |
| Debian | jackson-core | source | bookworm | 2.13.0-1 | not yet assigned | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libjackson2-core-java]Fixed
Source package: [jackson-core]
Details (4)
2.14.1-2~deb12u1· all · bookwormFixed · Fixed:
2.13.0-1dsa · jackson-core · debian · bookworm; dsa · jackson-core · debian · 12
2.14.1-2~deb12u1· all · bookwormFixed · Fixed:
2.13.0-1dsa · jackson-core · debian · bookworm; dsa · jackson-core · debian · 12
2.14.1-2~deb12u1· all · bookworm-securityFixed · Fixed:
2.13.0-1dsa · jackson-core · debian · bookworm; dsa · jackson-core · debian · 12
2.14.1-2~deb12u1· all · bookworm-securityFixed · Fixed:
2.13.0-1dsa · jackson-core · debian · bookworm; dsa · jackson-core · debian · 12
[Debian 13 (Trixie)]
- [libjackson2-core-java]Fixed
Source package: [jackson-core]
Details (4)
2.14.1-2~deb13u1· all · trixieFixed · Fixed:
2.13.0-1dsa · jackson-core · debian · 13
2.14.1-2~deb13u1· all · trixieFixed · Fixed:
2.13.0-1dsa · jackson-core · debian · 13
2.14.1-2~deb13u1· all · trixie-securityFixed · Fixed:
2.13.0-1dsa · jackson-core · debian · 13
2.14.1-2~deb13u1· all · trixie-securityFixed · Fixed:
2.13.0-1dsa · jackson-core · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-49128]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-49128]
- [https://security-tracker.debian.org/tracker/CVE-2025-49128]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-49128.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1262.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]