
CVE catalog
CVE-2025-52434
tomcat9: CVE-2025-52434
- Severity
- Medium · CVSS 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.07% · Oct 25, 2026
Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat when using the APR/Native connector. This was particularly noticeable with client initiated closes of HTTP/2 connections. This issue affects Apache Tomcat: from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.107, which fixes the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | tomcat9 | sid | 9.0.122-1 | fixed |
| Debian | tomcat9 | forky | 9.0.122-1 | fixed |
| Debian | tomcat9 | trixie | 9.0.95-1 | fixed |
| Debian | tomcat9 | bookworm | 9.0.70-2 | fixed |
| Ubuntu | tomcat8 | pro | 8.5.21-1ubuntu1 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.29-1 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.30-1 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.30-1ubuntu1 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.30-1ubuntu1.2 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.30-1ubuntu1.3 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.30-1ubuntu1.4 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.1 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.2 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.3 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.3+esm1 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.3+esm2 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.3+esm3 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.3+esm4 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.3+esm5 | vulnerable |
| Ubuntu | tomcat8 | pro | 8.5.39-1ubuntu1~18.04.3+esm6 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.43-3 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.54-1 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.55-1 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.1 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.1+esm1 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.1+esm2 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.1+esm3 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.1+esm4 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.2 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.2+esm1 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.2+esm2 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.2+esm3 | vulnerable |
| Ubuntu | tomcat9 | pro | 9.0.58-1ubuntu0.2+esm4 | vulnerable |
| Opensuse | tomcat | tumbleweed | 9.0.107-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | tomcat9 | source | sid | 9.0.70-2 | not yet assigned | Not reported | Not reported |
| Debian | tomcat9 | source | forky | 9.0.70-2 | not yet assigned | Not reported | Not reported |
| Debian | tomcat9 | source | trixie | 9.0.70-2 | not yet assigned | Not reported | Not reported |
| Debian | tomcat9 | source | bookworm | 9.0.70-2 | not yet assigned | Not reported | Not reported |
| Opensuse | tomcat | rpm | tumbleweed | 9.0.107-1.1 | Not reported | OPENSUSE-SU-2025:15440-1 | Not reported |
OpenFactory catalog packages
[openSUSE Tumbleweed]
- [tomcat-admin-webapps]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-docs-webapp]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-el-3_0-api]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-embed]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-javadoc]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-jsp-2_3-api]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-jsvc]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-lib]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-servlet-4_0-api]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat-webapps]Unknown
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedUnknown · Fixed:
9.0.107-1.1Version impact unknown
dsa · tomcat · opensuse · tumbleweed
- [tomcat]Fixed
Source package: [tomcat]
Details (1)
9.0.120-2.1· noarch · tumbleweedFixed · Fixed:
9.0.107-1.1dsa · tomcat · opensuse · tumbleweed
[Debian 12 (Bookworm)]
- [libtomcat9-java]Fixed
Source package: [tomcat9]
Details (2)
9.0.70-2· all · bookwormFixed · Fixed:
9.0.70-2dsa · tomcat9 · debian · bookworm; dsa · tomcat9 · debian · 12
9.0.70-2· all · bookwormFixed · Fixed:
9.0.70-2dsa · tomcat9 · debian · bookworm; dsa · tomcat9 · debian · 12
[Debian 13 (Trixie)]
- [libtomcat9-java]Fixed
Source package: [tomcat9]
Details (2)
9.0.95-1· all · trixieFixed · Fixed:
9.0.70-2dsa · tomcat9 · debian · 13
9.0.95-1· all · trixieFixed · Fixed:
9.0.70-2dsa · tomcat9 · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2025_14177.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-52434]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-52434]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:15440-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-52434]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-52434.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1905.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]