
CVE catalog
CVE-2025-52891
modsecurity-apache: CVE-2025-52891
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.38% · Oct 25, 2026
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.8 to before 2.9.11, an empty XML tag can cause a segmentation fault. If SecParseXmlIntoArgs is set to On or OnlyArgs, and the request type is application/xml, and at least one XML tag is empty (eg <foo></foo>), then a segmentation fault occurs. This issue has been patched in version 2.9.11. A workaround involves setting SecParseXmlIntoArgs to Off.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | modsecurity-apache | sid | 2.9.13-1 | fixed |
| Debian | modsecurity-apache | forky | 2.9.13-1 | fixed |
| Debian | modsecurity-apache | trixie | 2.9.11-1+deb13u1 | fixed |
| Debian | modsecurity-apache | bookworm | 2.9.7-1+deb12u2 | not affected |
| Debian | modsecurity-apache | bookworm-security | 2.9.7-1+deb12u1 | not affected |
| Opensuse | apache2-mod_security2 | tumbleweed | 2.9.11-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | modsecurity-apache | source | sid | 2.9.11-1 | not yet assigned | Not reported | [1108715] |
| Debian | modsecurity-apache | source | forky | 2.9.11-1 | not yet assigned | Not reported | [1108715] |
| Debian | modsecurity-apache | source | trixie | 2.9.11-1 | not yet assigned | Not reported | [1108715] |
| Debian | modsecurity-apache | source | bookworm | Not affected | unimportant | Not reported | [1108715] |
| Opensuse | apache2-mod_security2 | rpm | tumbleweed | 2.9.11-1.1 | Not reported | OPENSUSE-SU-2025:15313-1 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libapache2-mod-security2]Not affected
Source package: [modsecurity-apache]
Details (4)
2.9.7-1+deb12u2· amd64 · bookwormNot affected
dsa · modsecurity-apache · debian · bookworm
2.9.7-1+deb12u2· arm64 · bookwormNot affected
dsa · modsecurity-apache · debian · bookworm
2.9.7-1+deb12u1· amd64 · bookworm-securityNot affected
dsa · modsecurity-apache · debian · bookworm
2.9.7-1+deb12u1· arm64 · bookworm-securityNot affected
dsa · modsecurity-apache · debian · bookworm
[Debian 13 (Trixie)]
- [libapache2-mod-security2]Fixed
Source package: [modsecurity-apache]
Details (2)
2.9.11-1+deb13u1· amd64 · trixieFixed · Fixed:
2.9.11-1dsa · modsecurity-apache · debian · 13
2.9.11-1+deb13u1· arm64 · trixieFixed · Fixed:
2.9.11-1dsa · modsecurity-apache · debian · 13
[openSUSE Tumbleweed]
- [apache2-mod_security2]Fixed
Source package: [apache2-mod_security2]
Details (1)
2.9.12-1.7· x86_64 · tumbleweedFixed · Fixed:
2.9.11-1.1dsa · apache2-mod_security2 · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2025_15313-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-52891]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:15313-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-52891]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-52891.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1441.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]