
CVE catalog
CVE-2025-53000
nbconvert: CVE-2025-53000
- Severity
- High · CVSS 7.8
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.26% · Oct 25, 2026
The nbconvert tool, jupyter nbconvert, converts Jupyter notebooks to various other formats via Jinja templates. Versions of nbconvert up to and including 7.16.6 on Windows have a vulnerability in which converting a notebook containing SVG output to a PDF results in unauthorized code execution. Specifically, a third party can create a `inkscape.bat` file that defines a Windows batch script, capable of arbitrary code execution. When a user runs `jupyter nbconvert --to pdf` on a notebook containing SVG output to a PDF on a Windows platform from this directory, the `inkscape.bat` file is run unexpectedly. This issue has been patched in version 7.17.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | nbconvert | sid | 7.17.1-2 | not affected |
| Debian | nbconvert | forky | 7.17.1-2 | not affected |
| Debian | nbconvert | trixie | 7.16.6-1+deb13u1 | not affected |
| Debian | nbconvert | bookworm | 6.5.3-3 | not affected |
| PyPI | nbconvert | Not reported | 7.17.0 | fixed |
| PyPI | nbconvert | Not reported | 7.17.0 | fixed |
| Opensuse | python-nbconvert | tumbleweed | 7.17.1-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | nbconvert | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | nbconvert | source | forky | Not affected | unimportant | Not reported | Not reported |
| Debian | nbconvert | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | nbconvert | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| PyPI | nbconvert | PyPI | Not reported | 7.17.0 | Not reported | GHSA-XM59-RQC7-HHVF | Not reported |
| PyPI | nbconvert | PyPI | Not reported | 7.17.0 | Not reported | PYSEC-2026-1691 | Not reported |
| Opensuse | python-nbconvert | rpm | tumbleweed | 7.17.1-1.1 | Not reported | OPENSUSE-SU-2026:10603-1 | Not reported |
OpenFactory catalog packages
[openSUSE Tumbleweed]
- [jupyter-nbconvert]Unknown
Source package: [python-nbconvert]
Details (1)
7.17.1-1.4· noarch · tumbleweedUnknown · Fixed:
7.17.1-1.1Version impact unknown
dsa · python-nbconvert · opensuse · tumbleweed
- [jupyter-nbconvert-latex]Unknown
Source package: [python-nbconvert]
Details (1)
7.17.1-1.4· noarch · tumbleweedUnknown · Fixed:
7.17.1-1.1Version impact unknown
dsa · python-nbconvert · opensuse · tumbleweed
- [python313-nbconvert]Unknown
Source package: [python-nbconvert]
Details (1)
7.17.1-1.4· noarch · tumbleweedUnknown · Fixed:
7.17.1-1.1Version impact unknown
dsa · python-nbconvert · opensuse · tumbleweed
- [python314-nbconvert]Unknown
Source package: [python-nbconvert]
Details (1)
7.17.1-1.4· noarch · tumbleweedUnknown · Fixed:
7.17.1-1.1Version impact unknown
dsa · python-nbconvert · opensuse · tumbleweed
[Debian 12 (Bookworm)]
- [jupyter-nbconvert]Not affected
Source package: [nbconvert]
Details (2)
6.5.3-3· all · bookwormNot affected
dsa · nbconvert · debian · bookworm
6.5.3-3· all · bookwormNot affected
dsa · nbconvert · debian · bookworm
- [python3-nbconvert]Not affected
Source package: [nbconvert]
Details (2)
6.5.3-3· all · bookwormNot affected
dsa · nbconvert · debian · bookworm
6.5.3-3· all · bookwormNot affected
dsa · nbconvert · debian · bookworm
- [python-nbconvert-doc]Not affected
Source package: [nbconvert]
Details (2)
6.5.3-3· all · bookwormNot affected
dsa · nbconvert · debian · bookworm
6.5.3-3· all · bookwormNot affected
dsa · nbconvert · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_10603-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-53000]
- [https://osv.dev/vulnerability/PYSEC-2026-1691]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:10603-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-53000]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-53000.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]