
CVE catalog
CVE-2025-54571
modsecurity-apache: CVE-2025-54571
- Severity
- Medium · CVSS 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.31% · Oct 25, 2026
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | modsecurity-apache | sid | 2.9.13-1 | fixed |
| Debian | modsecurity-apache | forky | 2.9.13-1 | fixed |
| Debian | modsecurity-apache | trixie | 2.9.11-1+deb13u1 | fixed |
| Debian | modsecurity-apache | bookworm | 2.9.7-1+deb12u2 | fixed |
| Debian | modsecurity-apache | bookworm-security | 2.9.7-1+deb12u1 | vulnerable |
| Opensuse | apache2-mod_security2 | tumbleweed | 2.9.12-1.1 | fixed |
| Suse | apache2-mod_security2 | linux enterprise server ltss extended security 12 sp5 | 2.8.0-7.12.1 | fixed |
| Suse | apache2-mod_security2 | linux enterprise module for server applications 15 sp6 | 2.9.4-150400.3.12.1 | fixed |
| Suse | apache2-mod_security2 | linux enterprise module for server applications 15 sp7 | 2.9.4-150400.3.12.1 | fixed |
| Opensuse | apache2-mod_security2 | leap 15.6 | 2.9.4-150400.3.12.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | modsecurity-apache | source | sid | 2.9.12-2 | not yet assigned | Not reported | [1110480] |
| Debian | modsecurity-apache | source | forky | 2.9.12-2 | not yet assigned | Not reported | [1110480] |
| Debian | modsecurity-apache | source | trixie | 2.9.11-1+deb13u1 | not yet assigned | Not reported | [1110480] |
| Debian | modsecurity-apache | source | bookworm | 2.9.7-1+deb12u2 | not yet assigned | Not reported | [1110480] |
| Opensuse | apache2-mod_security2 | rpm | tumbleweed | 2.9.12-1.1 | Not reported | OPENSUSE-SU-2025:15456-1 | Not reported |
| Suse | apache2-mod_security2 | rpm | linux enterprise server ltss extended security 12 sp5 | 2.8.0-7.12.1 | Not reported | SUSE-SU-2025:03423-1 | Not reported |
| Suse | apache2-mod_security2 | rpm | linux enterprise module for server applications 15 sp6 | 2.9.4-150400.3.12.1 | Not reported | SUSE-SU-2025:03422-1 | Not reported |
| Suse | apache2-mod_security2 | rpm | linux enterprise module for server applications 15 sp7 | 2.9.4-150400.3.12.1 | Not reported | SUSE-SU-2025:03422-1 | Not reported |
| Opensuse | apache2-mod_security2 | rpm | leap 15.6 | 2.9.4-150400.3.12.1 | Not reported | SUSE-SU-2025:03422-1 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libapache2-mod-security2]Affected
Source package: [modsecurity-apache]
Details (4)
2.9.7-1+deb12u2· amd64 · bookwormFixed · Fixed:
2.9.7-1+deb12u2dsa · modsecurity-apache · debian · bookworm; dsa · modsecurity-apache · debian · 12
2.9.7-1+deb12u2· arm64 · bookwormFixed · Fixed:
2.9.7-1+deb12u2dsa · modsecurity-apache · debian · bookworm; dsa · modsecurity-apache · debian · 12
2.9.7-1+deb12u1· amd64 · bookworm-securityAffected · Fixed:
2.9.7-1+deb12u2dsa · modsecurity-apache · debian · bookworm; dsa · modsecurity-apache · debian · 12
2.9.7-1+deb12u1· arm64 · bookworm-securityAffected · Fixed:
2.9.7-1+deb12u2dsa · modsecurity-apache · debian · bookworm; dsa · modsecurity-apache · debian · 12
[Debian 13 (Trixie)]
- [libapache2-mod-security2]Fixed
Source package: [modsecurity-apache]
Details (2)
2.9.11-1+deb13u1· amd64 · trixieFixed · Fixed:
2.9.11-1+deb13u1dsa · modsecurity-apache · debian · 13
2.9.11-1+deb13u1· arm64 · trixieFixed · Fixed:
2.9.11-1+deb13u1dsa · modsecurity-apache · debian · 13
[openSUSE Tumbleweed]
- [apache2-mod_security2]Fixed
Source package: [apache2-mod_security2]
Details (1)
2.9.12-1.7· x86_64 · tumbleweedFixed · Fixed:
2.9.12-1.1dsa · apache2-mod_security2 · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2025_03422-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-54571]
- [https://osv.dev/vulnerability/DLA-4294-1]
- [https://osv.dev/vulnerability/SUSE-SU-2025:03422-1]
- [https://osv.dev/vulnerability/SUSE-SU-2025:03423-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:15456-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-54571]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-54571.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1202.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]