
CVE catalog
CVE-2025-54572
ruby-saml: CVE-2025-54572
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.43% · Oct 25, 2026
The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-saml | bookworm | 1.13.0-1+deb12u1 | vulnerable |
| Debian | ruby-saml | bookworm-security | 1.13.0-1+deb12u1 | vulnerable |
| Ubuntu | ruby-saml | pro | 1.15.0-1 | vulnerable |
| Ubuntu | ruby-saml | pro | 1.15.0-1ubuntu0.24.04.1 | vulnerable |
| Ubuntu | ruby-saml | pro | 1.15.0-1ubuntu0.24.04.1+esm1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-saml | source | bookworm | (unfixed) | end-of-life | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ruby-saml]Affected
Details (4)
1.13.0-1+deb12u1· all · bookwormAffected
dsa · ruby-saml · debian · bookworm; dsa · ruby-saml · debian · 12
1.13.0-1+deb12u1· all · bookwormAffected
dsa · ruby-saml · debian · bookworm; dsa · ruby-saml · debian · 12
1.13.0-1+deb12u1· all · bookworm-securityAffected
dsa · ruby-saml · debian · bookworm; dsa · ruby-saml · debian · 12
1.13.0-1+deb12u1· all · bookworm-securityAffected
dsa · ruby-saml · debian · bookworm; dsa · ruby-saml · debian · 12
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-54572]
- [https://osv.dev/vulnerability/DLA-4288-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-54572]
- [https://security-tracker.debian.org/tracker/CVE-2025-54572]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1686.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database]