
CVE catalog
CVE-2025-54574
squid: CVE-2025-54574
- Severity
- High · CVSS 8.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 23.96% · Oct 25, 2026
Squid is a caching proxy for the Web. In versions 6.3 and below, Squid is vulnerable to a heap buffer overflow and possible remote code execution attack when processing URN due to incorrect buffer management. This has been fixed in version 6.4. To work around this issue, disable URN access permissions.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | squid | sid | 7.7-1 | fixed |
| Debian | squid | forky | 7.7-1 | fixed |
| Debian | squid | trixie | 6.13-2+deb13u3 | fixed |
| Debian | squid | trixie-security | 6.13-2+deb13u2 | fixed |
| Debian | squid | bookworm | 5.7-2+deb12u5 | fixed |
| Debian | squid | bookworm-security | 5.7-2+deb12u6 | fixed |
| Ubuntu | squid3 | pro | 3.5.23-5ubuntu1 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.23-5ubuntu2 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.1 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.2 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.3 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.4 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.5 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.6 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.7 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.8 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.9 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.10 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.11 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.12 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.13 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm1 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm2 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm3 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm4 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm5 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm6 | vulnerable |
| Ubuntu | squid | 20.04 | 4.8-1ubuntu2 | vulnerable |
| Ubuntu | squid | 20.04 | 4.8-1ubuntu3 | vulnerable |
| Ubuntu | squid | 20.04 | 4.9-2ubuntu1 | vulnerable |
| Ubuntu | squid | 20.04 | 4.9-2ubuntu2 | vulnerable |
| Ubuntu | squid | 20.04 | 4.9-2ubuntu3 | vulnerable |
| Ubuntu | squid | 20.04 | 4.9-2ubuntu4 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.1 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.2 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.3 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.4 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.5 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.6 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.7 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.8 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.9 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.10 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.11 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.12 | fixed |
| Ubuntu | squid | 22.04 | 4.13-10ubuntu5 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu1 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu3 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu4 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu4.1 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu4.2 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu4.3 | vulnerable |
| Ubuntu | squid | 22.04 | 5.7-0ubuntu0.22.04.1 | vulnerable |
| Ubuntu | squid | 22.04 | 5.7-0ubuntu0.22.04.2 | vulnerable |
| Ubuntu | squid | 22.04 | 5.7-0ubuntu0.22.04.3 | vulnerable |
| Ubuntu | squid | 22.04 | 5.7-0ubuntu0.22.04.4 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | squid | source | sid | 6.5-1 | not yet assigned | Not reported | Not reported |
| Debian | squid | source | forky | 6.5-1 | not yet assigned | Not reported | Not reported |
| Debian | squid | source | trixie | 6.5-1 | not yet assigned | Not reported | Not reported |
| Debian | squid | source | bookworm | 5.7-2+deb12u3 | not yet assigned | Not reported | Not reported |
| Ubuntu | squid | deb | 20.04 | 4.10-1ubuntu1.12 | Not reported | UBUNTU-CVE-2025-54574 | Not reported |
| Ubuntu | squid | deb | 22.04 | 5.7-0ubuntu0.22.04.4 | Not reported | UBUNTU-CVE-2025-54574 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2023_7465.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-54574]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-54574]
- [https://security-tracker.debian.org/tracker/CVE-2025-54574]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-54574.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1696.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]