
CVE catalog
CVE-2025-5459
A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary host. It affects Puppet Enterprise versions 2018.1.
- Severity
- High · CVSS 8.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.06% · Oct 25, 2026
A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary host. It affects Puppet Enterprise versions 2018.1.8 through 2023.8.3 and 2025.3 and has been resolved in versions 2023.8.4 and 2025.4.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | puppetserver | sid | 8.7.0-7 | not affected |
| Debian | puppetserver | trixie | 8.7.0-5 | not affected |
| Debian | puppetserver | bookworm | 7.9.5-2+deb12u1 | not affected |
| Cpe | puppet_enterprise | Not reported | 2023.8.4 | fixed |
| Cpe | puppet_enterprise | Not reported | Not reported | unknown |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | puppetserver | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | puppetserver | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | puppetserver | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Cpe | puppet_enterprise | cpe | Not reported | 2023.8.4 | Not reported | NVD-CVE-2025-5459 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [puppet-master]Not affected
Source package: [puppetserver]
Details (2)
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
- [puppet-master-passenger]Not affected
Source package: [puppetserver]
Details (2)
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
- [puppetserver]Not affected
Details (2)
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-5459]
- [https://security-tracker.debian.org/tracker/CVE-2025-5459]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1401.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)]