
CVE catalog
CVE-2025-55702
trafficserver: CVE-2025-55702
- Severity
- High · CVSS 7
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.33% · Oct 25, 2026
When a client sends a POST with Expect: 100-continue and the origin answers before reading the body, Apache Traffic Server parses the unread body left on the client connection as the next request. An attacker behind a front-end proxy that shares connections to Traffic Server can use this to smuggle requests past the front end and desynchronize responses for other users. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.15, from 10.0.0 through 10.1.4, 10.2.0. Users are recommended to upgrade to version 9.2.16, 10.1.5, or 10.2.1, which fix the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | trafficserver | bookworm | 9.2.5+ds-0+deb12u4 | vulnerable |
| Debian | trafficserver | bookworm-security | 9.2.5+ds-0+deb12u4 | vulnerable |
| Ubuntu | trafficserver | 16.04 | 5.3.0-2ubuntu1 | vulnerable |
| Ubuntu | trafficserver | 16.04 | 5.3.0-2ubuntu2 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.0.0-5 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-2 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-2build1 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-3 | vulnerable |
| Ubuntu | trafficserver | pro | 8.1.1+ds-1.1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2build1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1+esm1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.1+ds-1build1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.2+ds-1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build3 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build4 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1ubuntu0.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | trafficserver | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [trafficserver]Affected
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
- [trafficserver-dev]Affected
Source package: [trafficserver]
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
- [trafficserver-experimental-plugins]Affected
Source package: [trafficserver]
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityAffected
dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-55702]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-55702]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-55702]
- [https://security-tracker.debian.org/tracker/CVE-2025-55702]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]