
CVE catalog
CVE-2025-58057
Netty vulnerabilities
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.63% · Oct 25, 2026
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | netty | sid | 1:4.1.48-16 | fixed |
| Debian | netty | forky | 1:4.1.48-16 | fixed |
| Debian | netty | trixie | 1:4.1.48-10+deb13u1 | fixed |
| Debian | netty | trixie-security | 1:4.1.48-10+deb13u1 | fixed |
| Debian | netty | bookworm | 1:4.1.48-7+deb12u2 | fixed |
| Debian | netty | bookworm-security | 1:4.1.48-7+deb12u2 | fixed |
| Ubuntu | netty | noble | Not reported | vulnerable |
| Ubuntu | netty | noble | 1:4.1.48-9ubuntu0.1 | fixed |
| Ubuntu | libnetty-java | noble | 1:4.1.48-9ubuntu0.1 | fixed |
| Cpe | netty | Not reported | 4.2.5 | fixed |
| Ubuntu | netty | pro | 1:4.1.33-1 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.33-2 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.33-3 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1ubuntu0.1~esm3 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1ubuntu0.1~esm4 | fixed |
| Ubuntu | netty | 22.04 | 1:4.1.48-4 | vulnerable |
| Ubuntu | netty | 22.04 | 1:4.1.48-4+deb11u1build0.22.04.1 | vulnerable |
| Ubuntu | netty | 22.04 | 1:4.1.48-4+deb11u2build0.22.04.1 | vulnerable |
| Ubuntu | netty | 22.04 | 1:4.1.48-4+deb11u2ubuntu0.1 | fixed |
| Ubuntu | netty | 24.04 | 1:4.1.48-7 | vulnerable |
| Ubuntu | netty | 24.04 | 1:4.1.48-8 | vulnerable |
| Ubuntu | netty | 24.04 | 1:4.1.48-9 | vulnerable |
| Ubuntu | netty | 24.04 | 1:4.1.48-9ubuntu0.1 | fixed |
| Ubuntu | netty | 25.10 | 1:4.1.48-10 | vulnerable |
| Ubuntu | netty | 25.10 | 1:4.1.48-10ubuntu0.25.10.1 | vulnerable |
| Ubuntu | netty | 25.10 | 1:4.1.48-10ubuntu0.25.10.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | netty | source | sid | 1:4.1.48-12 | not yet assigned | Not reported | [1113994] |
| Debian | netty | source | forky | 1:4.1.48-12 | not yet assigned | Not reported | [1113994] |
| Debian | netty | source | trixie | 1:4.1.48-10+deb13u1 | not yet assigned | Not reported | [1113994] |
| Debian | netty | source | bookworm | 1:4.1.48-7+deb12u2 | not yet assigned | Not reported | [1113994] |
| Ubuntu | netty | deb | noble | 1:4.1.48-9ubuntu0.1 | Not reported | Not reported | Not reported |
| Ubuntu | libnetty-java | deb | noble | 1:4.1.48-9ubuntu0.1 | Not reported | Not reported | Not reported |
| Cpe | netty | cpe | Not reported | 4.2.5 | Not reported | NVD-CVE-2025-58057 | Not reported |
| Ubuntu | netty | deb | pro | 1:4.1.45-1ubuntu0.1~esm4 | Not reported | UBUNTU-CVE-2025-58057 | Not reported |
| Ubuntu | netty | deb | 22.04 | 1:4.1.48-4+deb11u2ubuntu0.1 | Not reported | UBUNTU-CVE-2025-58057 | Not reported |
| Ubuntu | netty | deb | 24.04 | 1:4.1.48-9ubuntu0.1 | Not reported | UBUNTU-CVE-2025-58057 | Not reported |
| Ubuntu | netty | deb | 25.10 | 1:4.1.48-10ubuntu0.25.10.2 | Not reported | UBUNTU-CVE-2025-58057 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libnetty-java]Fixed
Source package: [netty]
Details (4)
1:4.1.48-7+deb12u2· all · bookwormFixed · Fixed:
1:4.1.48-7+deb12u2usn · netty · debian · bookworm; usn · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookwormFixed · Fixed:
1:4.1.48-7+deb12u2usn · netty · debian · bookworm; usn · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityFixed · Fixed:
1:4.1.48-7+deb12u2usn · netty · debian · bookworm; usn · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityFixed · Fixed:
1:4.1.48-7+deb12u2usn · netty · debian · bookworm; usn · netty · debian · 12
[Debian 13 (Trixie)]
- [libnetty-java]Fixed
Source package: [netty]
Details (4)
1:4.1.48-10+deb13u1· all · trixieFixed · Fixed:
1:4.1.48-10+deb13u1usn · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixieFixed · Fixed:
1:4.1.48-10+deb13u1usn · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityFixed · Fixed:
1:4.1.48-10+deb13u1usn · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityFixed · Fixed:
1:4.1.48-10+deb13u1usn · netty · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2025_03114-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-58057]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-58057]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-58057]
- [https://security-tracker.debian.org/tracker/CVE-2025-58057]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-58057.json]
- [https://ubuntu.com/security/notices/USN-7918-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1192.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX] · [Ubuntu Security Notices (USN)]