
CVE catalog
CVE-2025-58136
A bug in POST request handling causes a crash under a certain condition. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.1, from 9.0.0 through 9.2.12. Users are recommended to upg
- Severity
- High · CVSS 7.5
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.67% · Oct 25, 2026
A bug in POST request handling causes a crash under a certain condition. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.1, from 9.0.0 through 9.2.12. Users are recommended to upgrade to version 10.1.2 or 9.2.13, which fix the issue. A workaround for older versions is to set proxy.config.http.request_buffer_enabled to 0 (the default value is 0).
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | trafficserver | bookworm | 9.2.5+ds-0+deb12u4 | fixed |
| Debian | trafficserver | bookworm-security | 9.2.5+ds-0+deb12u4 | fixed |
| Cpe | traffic_server | Not reported | 9.2.13 | fixed |
| Cpe | traffic_server | Not reported | 10.1.2 | fixed |
| Ubuntu | trafficserver | 16.04 | 5.3.0-2ubuntu1 | vulnerable |
| Ubuntu | trafficserver | 16.04 | 5.3.0-2ubuntu2 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.0.0-5 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-2 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-2build1 | vulnerable |
| Ubuntu | trafficserver | 18.04 | 7.1.2+ds-3 | vulnerable |
| Ubuntu | trafficserver | pro | 8.1.1+ds-1.1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2build1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1 | vulnerable |
| Ubuntu | trafficserver | pro | 9.1.1+ds-2ubuntu0.1+esm1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.1+ds-1build1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.2+ds-1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build1 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build3 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1build4 | vulnerable |
| Ubuntu | trafficserver | 24.04 | 9.2.3+ds-1+deb12u1ubuntu0.1 | vulnerable |
| Ubuntu | trafficserver | 25.10 | 9.2.5+ds-1ubuntu1 | vulnerable |
| Ubuntu | trafficserver | 25.10 | 9.2.5+ds-1ubuntu2 | vulnerable |
| Ubuntu | trafficserver | 25.10 | 9.2.5+ds-1ubuntu2.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | trafficserver | source | bookworm | 9.2.5+ds-0+deb12u4 | not yet assigned | Not reported | [1132717] |
| Cpe | traffic_server | cpe | Not reported | 9.2.13 | Not reported | Not reported | Not reported |
| Cpe | traffic_server | cpe | Not reported | 10.1.2 | Not reported | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [trafficserver]Fixed
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
- [trafficserver-dev]Fixed
Source package: [trafficserver]
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
Source package: [trafficserver]
Details (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityFixed · Fixed:
9.2.5+ds-0+deb12u4nvd · trafficserver · debian · bookworm; nvd · trafficserver · debian · 12
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-58136]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-58136]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-58136]
- [https://security-tracker.debian.org/tracker/CVE-2025-58136]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-58136.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-0978.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]