
CVE catalog
CVE-2025-59432
libscram-java: CVE-2025-59432
- Severity
- Medium · CVSS 6.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.70% · Oct 25, 2026
SCRAM (Salted Challenge Response Authentication Mechanism) is part of the family of Simple Authentication and Security Layer (SASL, RFC 4422) authentication mechanisms. Prior to version 3.2, a timing attack vulnerability exists in the SCRAM Java implementation. The issue arises because Arrays.equals was used to compare secret values such as client proofs and server signatures. Since Arrays.equals performs a short-circuit comparison, the execution time varies depending on how many leading bytes match. This behavior could allow an attacker to perform a timing side-channel attack and potentially infer sensitive authentication material. All users relying on SCRAM authentication are impacted. This vulnerability has been patched in version 3.1 by replacing Arrays.equals with MessageDigest.isEqual, which ensures constant-time comparison.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libscram-java | sid | 3.4-1 | fixed |
| Debian | libscram-java | forky | 3.4-1 | fixed |
| Debian | libscram-java | trixie | 3.1-1 | vulnerable |
| Debian | libscram-java | bookworm | 2.1-1 | vulnerable |
| Opensuse | ongres-scram | leap 16.0 | 3.1-160000.3.1 | fixed |
| Opensuse | ongres-scram | tumbleweed | 3.2-7.1 | fixed |
| Suse | ongres-scram | linux enterprise server 16.0 | 3.1-160000.3.1 | fixed |
| Suse | ongres-scram | linux enterprise server for sap applications 16.0 | 3.1-160000.3.1 | fixed |
| Suse | ongres-scram | linux enterprise module for server applications 15 sp6 | 2.1-150400.8.5.1 | fixed |
| Suse | ongres-scram | linux enterprise module for server applications 15 sp7 | 2.1-150400.8.5.1 | fixed |
| Opensuse | ongres-scram | leap 15.6 | 2.1-150400.8.5.1 | fixed |
| Ubuntu | scram | 18.04 | 0.15.0-1 | vulnerable |
| Ubuntu | scram | 18.04 | 0.15.0-1build1 | vulnerable |
| Ubuntu | scram | 18.04 | 0.16.0-1 | vulnerable |
| Ubuntu | scram | 18.04 | 0.16.2-1 | vulnerable |
| Ubuntu | scram | 20.04 | 0.16.2-1build1 | vulnerable |
| Ubuntu | scram | 20.04 | 0.16.2-1build2 | vulnerable |
| Ubuntu | scram | 22.04 | 0.16.2-3 | vulnerable |
| Ubuntu | scram | 24.04 | 0.16.2-3 | vulnerable |
| Ubuntu | scram | 24.04 | 0.16.2-3build1 | vulnerable |
| Ubuntu | scram | 24.04 | 0.16.2-3build3 | vulnerable |
| Ubuntu | scram | 24.04 | 0.16.2-3build4 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libscram-java | source | sid | 3.2-1 | not yet assigned | Not reported | [1116054] |
| Debian | libscram-java | source | forky | 3.2-1 | not yet assigned | Not reported | [1116054] |
| Debian | libscram-java | source | trixie | (unfixed) | not yet assigned | Not reported | [1116054] |
| Debian | libscram-java | source | bookworm | (unfixed) | not yet assigned | Not reported | [1116054] |
| Opensuse | ongres-scram | rpm | leap 16.0 | 3.1-160000.3.1 | Not reported | OPENSUSE-SU-2025:20059-1 | Not reported |
| Opensuse | ongres-scram | rpm | tumbleweed | 3.2-7.1 | Not reported | OPENSUSE-SU-2025:15680-1 | Not reported |
| Suse | ongres-scram | rpm | linux enterprise server 16.0 | 3.1-160000.3.1 | Not reported | SUSE-SU-2025:21016-1 | Not reported |
| Suse | ongres-scram | rpm | linux enterprise server for sap applications 16.0 | 3.1-160000.3.1 | Not reported | SUSE-SU-2025:21016-1 | Not reported |
| Suse | ongres-scram | rpm | linux enterprise module for server applications 15 sp6 | 2.1-150400.8.5.1 | Not reported | SUSE-SU-2025:4054-1 | Not reported |
| Suse | ongres-scram | rpm | linux enterprise module for server applications 15 sp7 | 2.1-150400.8.5.1 | Not reported | SUSE-SU-2025:4054-1 | Not reported |
| Opensuse | ongres-scram | rpm | leap 15.6 | 2.1-150400.8.5.1 | Not reported | SUSE-SU-2025:4054-1 | Not reported |
Notes
[trixie] libscram-java: Minor issue [bookworm] libscram-java: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libscram-java]Affected
Details (2)
2.1-1· all · bookwormAffected
dsa · libscram-java · debian · bookworm; dsa · libscram-java · debian · 12
2.1-1· all · bookwormAffected
dsa · libscram-java · debian · bookworm; dsa · libscram-java · debian · 12
[Debian 13 (Trixie)]
- [libscram-java]Affected
Details (2)
3.1-1· all · trixieAffected
dsa · libscram-java · debian · 13
3.1-1· all · trixieAffected
dsa · libscram-java · debian · 13
[openSUSE Tumbleweed]
- [ongres-scram-client]Unknown
Source package: [ongres-scram]
Details (1)
3.2-7.4· noarch · tumbleweedUnknown · Fixed:
3.2-7.1Version impact unknown
dsa · ongres-scram · opensuse · tumbleweed
- [ongres-scram-javadoc]Unknown
Source package: [ongres-scram]
Details (1)
3.2-7.4· noarch · tumbleweedUnknown · Fixed:
3.2-7.1Version impact unknown
dsa · ongres-scram · opensuse · tumbleweed
- [ongres-scram]Fixed
Source package: [ongres-scram]
Details (1)
3.2-7.4· noarch · tumbleweedFixed · Fixed:
3.2-7.1dsa · ongres-scram · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2025_21016-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-59432]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-59432]
- [https://osv.dev/vulnerability/SUSE-SU-2025:21016-1]
- [https://osv.dev/vulnerability/SUSE-SU-2025:4054-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-59432]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:15680-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:20059-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-59432]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-59432.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-0325.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]