
CVE catalog
CVE-2025-59840
vega.js: CVE-2025-59840
- Severity
- High · CVSS 8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.42% · Oct 25, 2026
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 6.2.0, applications meeting 2 conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. They are vulnerable if they use `vega` in an application that attaches `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window` and if they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). Patches are available in the following Vega applications. If using the latest Vega line (6.x), upgrade to `vega` `6.2.0` / `vega-expression` `6.1.0` / `vega-interpreter` `2.2.1` (if using AST evaluator mode). If using Vega in a non-ESM environment, upgrade to `vega-expression` `5.2.1` / `1.2.1` (if using AST evaluator mode). Some workarounds are available. Do not attach `vega` View instances to global variables, and do not attach `vega` to the global window. These practices of attaching the vega library and View instances may be convenient for debugging, but should not be used in production or in any situation where vega/vega-lite definitions could be provided by untrusted parties.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | vega.js | sid | 5.33.1+ds+~cs5.3.0-4 | fixed |
| Debian | vega.js | forky | 5.33.1+ds+~cs5.3.0-4 | fixed |
| Debian | vega.js | trixie | 5.28.0+ds+~cs5.3.0-1 | vulnerable |
| Debian | vega.js | bookworm | 5.22.1+ds+~3.1.0-4 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | vega.js | source | sid | 5.33.1+ds+~cs5.3.0-4 | not yet assigned | Not reported | [1125183] |
| Debian | vega.js | source | forky | 5.33.1+ds+~cs5.3.0-4 | not yet assigned | Not reported | [1125183] |
| Debian | vega.js | source | trixie | (unfixed) | not yet assigned | Not reported | [1125183] |
| Debian | vega.js | source | bookworm | (unfixed) | not yet assigned | Not reported | [1125183] |
Notes
[trixie] vega.js: Minor issue [bookworm] vega.js: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libjs-vega]Affected
Source package: [vega.js]
Details (2)
5.22.1+ds+~3.1.0-4· all · bookwormAffected
dsa · vega.js · debian · bookworm; dsa · vega.js · debian · 12
5.22.1+ds+~3.1.0-4· all · bookwormAffected
dsa · vega.js · debian · bookworm; dsa · vega.js · debian · 12
- [node-vega]Affected
Source package: [vega.js]
Details (2)
5.22.1+ds+~3.1.0-4· all · bookwormAffected
dsa · vega.js · debian · bookworm; dsa · vega.js · debian · 12
5.22.1+ds+~3.1.0-4· all · bookwormAffected
dsa · vega.js · debian · bookworm; dsa · vega.js · debian · 12
[Debian 13 (Trixie)]
- [libjs-vega]Affected
Source package: [vega.js]
Details (2)
5.28.0+ds+~cs5.3.0-1· all · trixieAffected
dsa · vega.js · debian · 13
5.28.0+ds+~cs5.3.0-1· all · trixieAffected
dsa · vega.js · debian · 13
- [node-vega]Affected
Source package: [vega.js]
Details (2)
5.28.0+ds+~cs5.3.0-1· all · trixieAffected
dsa · vega.js · debian · 13
5.28.0+ds+~cs5.3.0-1· all · trixieAffected
dsa · vega.js · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-59840]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-59840]
- [https://security-tracker.debian.org/tracker/CVE-2025-59840]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-59840.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-2576.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]