
CVE catalog
CVE-2025-59842
DEBIAN-CVE-2025-59842
- Severity
- Medium · CVSS 4.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.24% · Oct 25, 2026
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. Prior to version 4.4.8, links generated with LaTeX typesetters in Markdown files and Markdown cells in JupyterLab and Jupyter Notebook did not include the noopener attribute. This is deemed to have no impact on the default installations. Theoretically users of third-party LaTeX-rendering extensions could find themselves vulnerable to reverse tabnabbing attacks if links generated by those extensions included target=_blank (no such extensions are known at time of writing) and they were to click on a link generated in LaTeX (typically visibly different from other links). This issue has been patched in version 4.4.8.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| PyPI | jupyterlab | Not reported | 4.4.8 | fixed |
| PyPI | jupyterlab | Not reported | 4.4.8 | fixed |
| Cpe | jupyterlab | Not reported | 4.4.8 | fixed |
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-7 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-8 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-9 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds2+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds2+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds3+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds5+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.13+ds1+~2.0.1+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-7 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-8 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-9 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds2+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds2+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds3+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-4 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds5+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.13+ds1+~2.0.1+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3 | fixed |
| Opensuse | python-jupyterlab | tumbleweed | 4.4.9-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| PyPI | jupyterlab | PyPI | Not reported | 4.4.8 | Not reported | GHSA-VVFJ-2JQX-52JM | Not reported |
| PyPI | jupyterlab | PyPI | Not reported | 4.4.8 | Not reported | PYSEC-2026-1482 | Not reported |
| Cpe | jupyterlab | cpe | Not reported | 4.4.8 | Not reported | NVD-CVE-2025-59842 | Not reported |
| Debian | jupyterlab | deb | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3 | Not reported | DEBIAN-CVE-2025-59842 | Not reported |
| Opensuse | python-jupyterlab | rpm | tumbleweed | 4.4.9-1.1 | Not reported | OPENSUSE-SU-2025:15591-1 | Not reported |
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [jupyterlab]Affected
Details (2)
4.0.11+ds1+~cs11.25.27-7· all · trixieAffected
pypi · jupyterlab · debian · 13
4.0.11+ds1+~cs11.25.27-7· all · trixieAffected
pypi · jupyterlab · debian · 13
[openSUSE Tumbleweed]
- [jupyter-jupyterlab]Unknown
Source package: [python-jupyterlab]
Details (1)
4.5.10-1.1· noarch · tumbleweedUnknown · Fixed:
4.4.9-1.1Version impact unknown
pypi · python-jupyterlab · opensuse · tumbleweed
- [python313-jupyterlab]Unknown
Source package: [python-jupyterlab]
Details (1)
4.5.10-1.1· noarch · tumbleweedUnknown · Fixed:
4.4.9-1.1Version impact unknown
pypi · python-jupyterlab · opensuse · tumbleweed
- [python314-jupyterlab]Unknown
Source package: [python-jupyterlab]
Details (1)
4.5.10-1.1· noarch · tumbleweedUnknown · Fixed:
4.4.9-1.1Version impact unknown
pypi · python-jupyterlab · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2025_15591-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-59842]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-59842]
- [https://osv.dev/vulnerability/GHSA-vvfj-2jqx-52jm]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:15591-1]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-59842.json]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]