
CVE catalog
CVE-2025-59933
vips: CVE-2025-59933
- Severity
- Medium · CVSS 6.8
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.19% · Oct 25, 2026
libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | vips | sid | 8.18.7-1 | fixed |
| Debian | vips | forky | 8.18.7-1 | fixed |
| Debian | vips | trixie | 8.16.1-1+deb13u1 | vulnerable |
| Debian | vips | trixie-security | 8.16.1-1+deb13u2 | fixed |
| Debian | vips | bookworm | 8.14.1-3+deb12u3 | vulnerable |
| Debian | vips | bookworm-security | 8.14.1-3+deb12u2 | vulnerable |
| Cpe | libvips | Not reported | 8.17.2 | fixed |
| Ubuntu | vips | pro | 8.14.3-1 | vulnerable |
| Ubuntu | vips | pro | 8.14.5-1 | vulnerable |
| Ubuntu | vips | pro | 8.15.0-1 | vulnerable |
| Ubuntu | vips | pro | 8.15.0-2 | vulnerable |
| Ubuntu | vips | pro | 8.15.1-1 | vulnerable |
| Ubuntu | vips | pro | 8.15.1-1build1 | vulnerable |
| Ubuntu | vips | pro | 8.15.1-1.1build3 | vulnerable |
| Ubuntu | vips | pro | 8.15.1-1.1build4 | vulnerable |
| Ubuntu | vips | pro | 8.15.1-1.1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | vips | 25.10 | 8.16.0-2build1 | vulnerable |
| Ubuntu | vips | 25.10 | 8.16.1-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | vips | source | sid | 8.17.3-1 | not yet assigned | Not reported | [1117049] |
| Debian | vips | source | forky | 8.17.3-1 | not yet assigned | Not reported | [1117049] |
| Debian | vips | source | trixie | 8.16.1-1+deb13u2 | not yet assigned | Not reported | [1117049] |
| Debian | vips | source | bookworm | (unfixed) | not yet assigned | Not reported | [1117049] |
| Cpe | libvips | cpe | Not reported | 8.17.2 | Not reported | NVD-CVE-2025-59933 | Not reported |
Notes
[bookworm] vips: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [gir1.2-vips-8.0]Affected
Source package: [vips]
Details (4)
8.14.1-3+deb12u3· amd64 · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u3· arm64 · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· amd64 · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· arm64 · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
- [libvips42]Affected
Source package: [vips]
Details (4)
8.14.1-3+deb12u3· amd64 · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u3· arm64 · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· amd64 · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· arm64 · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
- [libvips-dev]Affected
Source package: [vips]
Details (4)
8.14.1-3+deb12u3· amd64 · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u3· arm64 · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· amd64 · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· arm64 · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
- [libvips-doc]Affected
Source package: [vips]
Details (4)
8.14.1-3+deb12u3· all · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u3· all · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· all · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· all · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
- [libvips-tools]Affected
Source package: [vips]
Details (4)
8.14.1-3+deb12u3· amd64 · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u3· arm64 · bookwormAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· amd64 · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
8.14.1-3+deb12u2· arm64 · bookworm-securityAffected
dsa · vips · debian · bookworm; dsa · vips · debian · 12
[Debian 13 (Trixie)]
- [gir1.2-vips-8.0]Affected
Source package: [vips]
Details (3)
8.16.1-1+deb13u1· amd64 · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u1· arm64 · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u2· amd64 · trixie-securityFixed · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
- [libvips42t64]Affected
Source package: [vips]
Details (3)
8.16.1-1+deb13u1· amd64 · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u1· arm64 · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u2· amd64 · trixie-securityFixed · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
- [libvips-dev]Affected
Source package: [vips]
Details (3)
8.16.1-1+deb13u1· amd64 · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u1· arm64 · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u2· amd64 · trixie-securityFixed · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
- [libvips-doc]Affected
Source package: [vips]
Details (3)
8.16.1-1+deb13u1· all · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u1· all · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u2· all · trixie-securityFixed · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
- [libvips-tools]Affected
Source package: [vips]
Details (3)
8.16.1-1+deb13u1· amd64 · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u1· arm64 · trixieAffected · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
8.16.1-1+deb13u2· amd64 · trixie-securityFixed · Fixed:
8.16.1-1+deb13u2dsa · vips · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-59933]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-59933]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-59933]
- [https://security-tracker.debian.org/tracker/CVE-2025-59933]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-59933.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]