
CVE catalog
CVE-2025-61669
Jupyter Server is the backend for Jupyter web applications. In jupyter_server versions through 2.17.0, the next query parameter in the login flow is insufficiently validated in `LoginFormHandler._redi
- Severity
- Medium · CVSS 6.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.24% · Oct 25, 2026
Jupyter Server is the backend for Jupyter web applications. In jupyter_server versions through 2.17.0, the next query parameter in the login flow is insufficiently validated in `LoginFormHandler._redirect_safe()`, which allows redirects to arbitrary external domains via values such as `///example.com`. An attacker can use a crafted login URL to redirect users to a malicious site and facilitate phishing attacks. This issue is fixed in version 2.18.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jupyter-server | sid | 2.20.0-3 | fixed |
| Debian | jupyter-server | forky | 2.20.0-3 | fixed |
| Debian | jupyter-server | trixie | 2.15.0-1 | vulnerable |
| Debian | jupyter-server | bookworm | 1.23.3-1 | vulnerable |
| Cpe | jupyter-server | Not reported | Not reported | vulnerable |
| Cpe | jupyter_server | Not reported | 2.18.0 | fixed |
| PyPI | jupyter-server | Not reported | 2.18.0 | fixed |
| PyPI | jupyter-server | Not reported | 2.18.0 | fixed |
| Cpe | jupyter_server | Not reported | 2.18.0 | fixed |
| Opensuse | python-jupyter-server | tumbleweed | 2.18.1-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jupyter-server | source | sid | 2.20.0-1 | not yet assigned | Not reported | [1136022] |
| Debian | jupyter-server | source | forky | 2.20.0-1 | not yet assigned | Not reported | [1136022] |
| Debian | jupyter-server | source | trixie | (unfixed) | not yet assigned | Not reported | [1136022] |
| Debian | jupyter-server | source | bookworm | (unfixed) | not yet assigned | Not reported | [1136022] |
| Cpe | jupyter_server | cpe | Not reported | 2.18.0 | Not reported | Not reported | Not reported |
| PyPI | jupyter-server | PyPI | Not reported | 2.18.0 | Not reported | GHSA-QH7Q-6QM3-653W | Not reported |
| PyPI | jupyter-server | PyPI | Not reported | 2.18.0 | Not reported | PYSEC-2026-67 | Not reported |
| Cpe | jupyter_server | cpe | Not reported | 2.18.0 | Not reported | NVD-CVE-2025-61669 | Not reported |
| Opensuse | python-jupyter-server | rpm | tumbleweed | 2.18.1-1.1 | Not reported | OPENSUSE-SU-2026:10710-1 | Not reported |
Notes
[trixie] jupyter-server: Minor issue [bookworm] jupyter-server: Minor issue; _redirect_safe next-param open redirect present, revisit with next update
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [jupyter-server]Affected
Details (2)
1.23.3-1· all · bookwormAffected
nvd · jupyter-server · debian · bookworm; nvd · jupyter-server · debian · 12
1.23.3-1· all · bookwormAffected
nvd · jupyter-server · debian · bookworm; nvd · jupyter-server · debian · 12
- [python3-jupyter-server]Affected
Source package: [jupyter-server]
Details (2)
1.23.3-1· all · bookwormAffected
nvd · jupyter-server · debian · bookworm; nvd · jupyter-server · debian · 12
1.23.3-1· all · bookwormAffected
nvd · jupyter-server · debian · bookworm; nvd · jupyter-server · debian · 12
[Debian 13 (Trixie)]
- [jupyter-server]Affected
Details (2)
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
- [python3-jupyter-server]Affected
Source package: [jupyter-server]
Details (2)
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
- [python-jupyter-server-doc]Affected
Source package: [jupyter-server]
Details (2)
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
[openSUSE Tumbleweed]
- [python313-jupyter-server]Unknown
Source package: [python-jupyter-server]
Details (1)
2.20.0-1.3· noarch · tumbleweedUnknown · Fixed:
2.18.1-1.1Version impact unknown
nvd · python-jupyter-server · opensuse · tumbleweed
- [python313-jupyter-server-test]Unknown
Source package: [python-jupyter-server]
Details (1)
2.20.0-1.3· noarch · tumbleweedUnknown · Fixed:
2.18.1-1.1Version impact unknown
nvd · python-jupyter-server · opensuse · tumbleweed
- [python314-jupyter-server]Unknown
Source package: [python-jupyter-server]
Details (1)
2.20.0-1.3· noarch · tumbleweedUnknown · Fixed:
2.18.1-1.1Version impact unknown
nvd · python-jupyter-server · opensuse · tumbleweed
- [python314-jupyter-server-test]Unknown
Source package: [python-jupyter-server]
Details (1)
2.20.0-1.3· noarch · tumbleweedUnknown · Fixed:
2.18.1-1.1Version impact unknown
nvd · python-jupyter-server · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_10710-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-61669]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-61669]
- [https://osv.dev/vulnerability/GHSA-qh7q-6qm3-653w]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:10710-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-61669]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-61669.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]