
CVE catalog
CVE-2025-61919
Rack vulnerabilities
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.65% · Oct 25, 2026
Rack is a modular Ruby web server interface. Prior to versions 2.2.20, 3.1.18, and 3.2.3, `Rack::Request#POST` reads the entire request body into memory for `Content-Type: application/x-www-form-urlencoded`, calling `rack.input.read(nil)` without enforcing a length or cap. Large request bodies can therefore be buffered completely into process memory before parsing, leading to denial of service (DoS) through memory exhaustion. Users should upgrade to Rack version 2.2.20, 3.1.18, or 3.2.3, anu of which enforces form parameter limits using `query_parser.bytesize_limit`, preventing unbounded reads of `application/x-www-form-urlencoded` bodies. Additionally, enforce strict maximum body size at the proxy or web server layer (e.g., Nginx `client_max_body_size`, Apache `LimitRequestBody`).
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-rack | sid | 3.2.7-1 | fixed |
| Debian | ruby-rack | forky | 3.2.7-1 | fixed |
| Debian | ruby-rack | trixie | 3.1.20-0+deb13u1 | fixed |
| Debian | ruby-rack | trixie-security | 3.1.20-0+deb13u2 | fixed |
| Debian | ruby-rack | bookworm | 2.2.22-0+deb12u1 | fixed |
| Debian | ruby-rack | bookworm-security | 2.2.22-0+deb12u2 | fixed |
| Ubuntu | ruby-rack | noble | 2.2.7-1ubuntu0.5 | fixed |
| Cpe | rack | Not reported | 3.2.3 | fixed |
| Ubuntu | ruby-rack | pro | 2.0.6-3 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1+esm1 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1+esm2 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1+esm3 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1+esm4 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1+esm5 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1+esm6 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1+esm7 | vulnerable |
| Ubuntu | ruby-rack | pro | 2.0.7-2ubuntu0.1+esm8 | fixed |
| Ubuntu | ruby-rack | 22.04 | 2.1.4-3 | vulnerable |
| Ubuntu | ruby-rack | 22.04 | 2.1.4-4 | vulnerable |
| Ubuntu | ruby-rack | 22.04 | 2.1.4-5 | vulnerable |
| Ubuntu | ruby-rack | 22.04 | 2.1.4-5ubuntu1 | vulnerable |
| Ubuntu | ruby-rack | 22.04 | 2.1.4-5ubuntu1.1 | vulnerable |
| Ubuntu | ruby-rack | 22.04 | 2.1.4-5ubuntu1.2 | fixed |
| Ubuntu | ruby-rack | 24.04 | 2.2.4-3 | vulnerable |
| Ubuntu | ruby-rack | 24.04 | 2.2.7-1 | vulnerable |
| Ubuntu | ruby-rack | 24.04 | 2.2.7-1ubuntu0.1 | vulnerable |
| Ubuntu | ruby-rack | 24.04 | 2.2.7-1ubuntu0.2 | vulnerable |
| Ubuntu | ruby-rack | 24.04 | 2.2.7-1ubuntu0.3 | vulnerable |
| Ubuntu | ruby-rack | 24.04 | 2.2.7-1ubuntu0.4 | vulnerable |
| Ubuntu | ruby-rack | 24.04 | 2.2.7-1ubuntu0.5 | fixed |
| Ubuntu | ruby-rack | 25.10 | 2.2.7-1.1 | vulnerable |
| Ubuntu | ruby-rack | 25.10 | 3.1.16-0.1 | vulnerable |
| Ubuntu | ruby-rack | 25.10 | 3.1.16-0.1ubuntu0.1 | fixed |
| Opensuse | rubygem-rack-2.2 | tumbleweed | 2.2.20-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-rack | source | sid | 3.1.18-1 | not yet assigned | Not reported | [1117856] |
| Debian | ruby-rack | source | forky | 3.1.18-1 | not yet assigned | Not reported | [1117856] |
| Debian | ruby-rack | source | trixie | 3.1.18-1~deb13u1 | not yet assigned | Not reported | [1117856] |
| Debian | ruby-rack | source | bookworm | 2.2.20-0+deb12u1 | not yet assigned | Not reported | [1117856] |
| Ubuntu | ruby-rack | deb | noble | 2.2.7-1ubuntu0.5 | Not reported | Not reported | Not reported |
| Cpe | rack | cpe | Not reported | 3.2.3 | Not reported | NVD-CVE-2025-61919 | Not reported |
| Ubuntu | ruby-rack | deb | pro | 2.0.7-2ubuntu0.1+esm8 | Not reported | UBUNTU-CVE-2025-61919 | Not reported |
| Ubuntu | ruby-rack | deb | 22.04 | 2.1.4-5ubuntu1.2 | Not reported | UBUNTU-CVE-2025-61919 | Not reported |
| Ubuntu | ruby-rack | deb | 24.04 | 2.2.7-1ubuntu0.5 | Not reported | UBUNTU-CVE-2025-61919 | Not reported |
| Ubuntu | ruby-rack | deb | 25.10 | 3.1.16-0.1ubuntu0.1 | Not reported | UBUNTU-CVE-2025-61919 | Not reported |
| Opensuse | rubygem-rack-2.2 | rpm | tumbleweed | 2.2.20-1.1 | Not reported | OPENSUSE-SU-2025:15642-1 | Not reported |
OpenFactory catalog packages
[openSUSE Tumbleweed]
- [ruby4.0-rubygem-rack-2.2]Unknown
Source package: [rubygem-rack-2.2]
Details (1)
2.2.23-1.3· x86_64 · tumbleweedUnknown · Fixed:
2.2.20-1.1Version impact unknown
usn · rubygem-rack-2.2 · opensuse · tumbleweed
[Debian 12 (Bookworm)]
- [ruby-rack]Fixed
Details (4)
2.2.22-0+deb12u1· all · bookwormFixed · Fixed:
2.2.20-0+deb12u1usn · ruby-rack · debian · bookworm; usn · ruby-rack · debian · 12
2.2.22-0+deb12u1· all · bookwormFixed · Fixed:
2.2.20-0+deb12u1usn · ruby-rack · debian · bookworm; usn · ruby-rack · debian · 12
2.2.22-0+deb12u2· all · bookworm-securityFixed · Fixed:
2.2.20-0+deb12u1usn · ruby-rack · debian · bookworm; usn · ruby-rack · debian · 12
2.2.22-0+deb12u2· all · bookworm-securityFixed · Fixed:
2.2.20-0+deb12u1usn · ruby-rack · debian · bookworm; usn · ruby-rack · debian · 12
[Debian 13 (Trixie)]
- [ruby-rack]Fixed
Details (5)
3.1.20-0+deb13u1· all · trixieFixed · Fixed:
3.1.18-1~deb13u1usn · ruby-rack · debian · 13
3.1.20-0+deb13u1· all · trixieFixed · Fixed:
3.1.18-1~deb13u1usn · ruby-rack · debian · 13
3.1.20-0+deb13u1· all · trixie-securityFixed · Fixed:
3.1.18-1~deb13u1usn · ruby-rack · debian · 13
3.1.20-0+deb13u1· all · trixie-security · Historical versionFixed · Fixed:
3.1.18-1~deb13u1usn · ruby-rack · debian · 13
3.1.20-0+deb13u2· all · trixie-securityFixed · Fixed:
3.1.18-1~deb13u1usn · ruby-rack · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2025_19719.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-61919]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-61919]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-61919]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:15642-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-61919]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-61919.json]
- [https://ubuntu.com/security/notices/USN-7960-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-2482.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX] · [Ubuntu Security Notices (USN)]