
CVE catalog
CVE-2025-62518
python311-uv-0.9.5-1.1 on GA media
- Severity
- High · CVSS 8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.70% · Oct 25, 2026
astral-tokio-tar is a tar archive reading/writing library for async Rust. Versions of astral-tokio-tar prior to 0.5.6 contain a boundary parsing vulnerability that allows attackers to smuggle additional archive entries by exploiting inconsistent PAX/ustar header handling. When processing archives with PAX-extended headers containing size overrides, the parser incorrectly advances stream position based on ustar header size (often zero) instead of the PAX-specified size, causing it to interpret file content as legitimate tar headers. This issue has been patched in version 0.5.6. There are no workarounds.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rust-astral-tokio-tar | 13 | 0.5.2-2 | vulnerable |
| Debian | rust-astral-tokio-tar | 13 | 0.5.5-1 | vulnerable |
| Debian | rust-astral-tokio-tar | 13 | 0.5.6-1 | vulnerable |
| Debian | rust-astral-tokio-tar | 13 | 0.5.6-2 | vulnerable |
| Debian | rust-astral-tokio-tar | 13 | 0.6.0-1 | vulnerable |
| Debian | rust-astral-tokio-tar | 13 | 0.6.1-1 | vulnerable |
| Debian | rust-astral-tokio-tar | 13 | 0.6.2-1 | vulnerable |
| Debian | rust-astral-tokio-tar | 13 | 0.6.4-1 | vulnerable |
| Debian | rust-astral-tokio-tar | 14 | 0.5.2-2 | vulnerable |
| Debian | rust-astral-tokio-tar | 14 | 0.5.5-1 | vulnerable |
| Debian | rust-astral-tokio-tar | 14 | 0.5.6-1 | fixed |
| Ubuntu | rust-astral-tokio-tar | 25.10 | 0.5.1-1 | vulnerable |
| Ubuntu | rust-astral-tokio-tar | 25.10 | 0.5.2-2 | vulnerable |
| Ubuntu | rust-astral-tokio-tar | 26.04 | 0.5.2-2 | vulnerable |
| Ubuntu | rust-astral-tokio-tar | 26.04 | 0.5.5-1 | vulnerable |
| Ubuntu | rust-astral-tokio-tar | 26.04 | 0.5.6-1 | vulnerable |
| Ubuntu | rust-astral-tokio-tar | 26.04 | 0.5.6-2 | vulnerable |
| Opensuse | python-uv | tumbleweed | 0.9.5-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rust-astral-tokio-tar | deb | 14 | 0.5.6-1 | Not reported | DEBIAN-CVE-2025-62518 | Not reported |
| Opensuse | python-uv | rpm | tumbleweed | 0.9.5-1.1 | Not reported | OPENSUSE-SU-2025:15658-1 | Not reported |
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [librust-astral-tokio-tar-dev]Affected
Source package: [rust-astral-tokio-tar]
Details (2)
0.5.2-2· amd64 · trixieAffected
pypi · rust-astral-tokio-tar · debian · 13
0.5.2-2· arm64 · trixieAffected
pypi · rust-astral-tokio-tar · debian · 13
[openSUSE Tumbleweed]
- [python313-uv]Unknown
Source package: [python-uv]
Details (1)
0.12.7-1.1· x86_64 · tumbleweedUnknown · Fixed:
0.9.5-1.1Version impact unknown
pypi · python-uv · opensuse · tumbleweed
- [python314-uv]Unknown
Source package: [python-uv]
Details (1)
0.12.7-1.1· x86_64 · tumbleweedUnknown · Fixed:
0.9.5-1.1Version impact unknown
pypi · python-uv · opensuse · tumbleweed
- [uv-bash-completion]Unknown
Source package: [python-uv]
Details (1)
0.12.7-1.1· noarch · tumbleweedUnknown · Fixed:
0.9.5-1.1Version impact unknown
pypi · python-uv · opensuse · tumbleweed
- [uv-fish-completion]Unknown
Source package: [python-uv]
Details (1)
0.12.7-1.1· noarch · tumbleweedUnknown · Fixed:
0.9.5-1.1Version impact unknown
pypi · python-uv · opensuse · tumbleweed
- [uv-zsh-completion]Unknown
Source package: [python-uv]
Details (1)
0.12.7-1.1· noarch · tumbleweedUnknown · Fixed:
0.9.5-1.1Version impact unknown
pypi · python-uv · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2025_15658-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-62518]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-62518]
- [https://osv.dev/vulnerability/openSUSE-SU-2025:15658-1]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-62518.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]