
CVE catalog
CVE-2025-64332
suricata: CVE-2025-64332
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.37% · Oct 25, 2026
Suricata is a network IDS, IPS and NSM engine developed by the OISF (Open Information Security Foundation) and the Suricata community. Prior to versions 7.0.13 and 8.0.2, a stack overflow that causes Suricata to crash can occur if SWF decompression is enabled. This issue has been patched in versions 7.0.13 and 8.0.2. A workaround for this issue involves disabling SWF decompression (swf-decompression in suricata.yaml), it is disabled by default; set decompress-depth to lower than half your stack size if swf-decompression must be enabled.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | suricata | bookworm | Not reported | vulnerable |
| Cpe | suricata | Not reported | 8.0.2 | fixed |
| Debian | suricata | 13 | 1:7.0.10-1 | vulnerable |
| Debian | suricata | 13 | 1:7.0.10-1+deb13u1 | vulnerable |
| Debian | suricata | 13 | 1:7.0.10-1+deb13u2 | fixed |
| Debian | suricata | 14 | 1:7.0.10-1 | vulnerable |
| Debian | suricata | 14 | 1:7.0.11-1 | vulnerable |
| Debian | suricata | 14 | 1:7.0.11-1~bpo13+1 | vulnerable |
| Debian | suricata | 14 | 1:8.0.0-1~exp1 | vulnerable |
| Debian | suricata | 14 | 1:8.0.0-1~exp2 | vulnerable |
| Debian | suricata | 14 | 1:8.0.0-1~exp4 | vulnerable |
| Debian | suricata | 14 | 1:8.0.0-1~exp5 | vulnerable |
| Debian | suricata | 14 | 1:8.0.1-1 | vulnerable |
| Debian | suricata | 14 | 1:8.0.1-2 | vulnerable |
| Debian | suricata | 14 | 1:8.0.1-3 | vulnerable |
| Debian | suricata | 14 | 1:8.0.1-3~bpo13+1 | vulnerable |
| Debian | suricata | 14 | 1:8.0.2-1~bpo13+1 | vulnerable |
| Debian | suricata | 14 | 1:8.0.2-1 | fixed |
| Ubuntu | suricata | 16.04 | 2.0.8-1build1 | vulnerable |
| Ubuntu | suricata | 16.04 | 2.0.9-1 | vulnerable |
| Ubuntu | suricata | 16.04 | 2.0.10-1 | vulnerable |
| Ubuntu | suricata | 16.04 | 2.0.10-2 | vulnerable |
| Ubuntu | suricata | 16.04 | 2.0.11-1 | vulnerable |
| Ubuntu | suricata | 16.04 | 3.0-1 | vulnerable |
| Ubuntu | suricata | 18.04 | 3.2-2ubuntu3 | vulnerable |
| Ubuntu | suricata | 22.04 | 1:6.0.4-2 | vulnerable |
| Ubuntu | suricata | 22.04 | 1:6.0.4-3 | vulnerable |
| Ubuntu | suricata | 24.04 | 1:7.0.0-2 | vulnerable |
| Ubuntu | suricata | 24.04 | 1:7.0.2-1 | vulnerable |
| Ubuntu | suricata | 24.04 | 1:7.0.2-1build1 | vulnerable |
| Ubuntu | suricata | 24.04 | 1:7.0.3-1build1 | vulnerable |
| Ubuntu | suricata | 24.04 | 1:7.0.3-1build3 | vulnerable |
| Ubuntu | suricata | 25.10 | 1:7.0.8-2 | vulnerable |
| Ubuntu | suricata | 25.10 | 1:7.0.10-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Cpe | suricata | cpe | Not reported | 8.0.2 | Not reported | NVD-CVE-2025-64332 | Not reported |
| Debian | suricata | deb | 13 | 1:7.0.10-1+deb13u2 | Not reported | DEBIAN-CVE-2025-64332 | Not reported |
| Debian | suricata | deb | 14 | 1:8.0.2-1 | Not reported | DEBIAN-CVE-2025-64332 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [suricata]Affected
Details (2)
1:7.0.10-1~bpo12+1· amd64 · bookworm-backportsAffected
dsa · suricata · debian · bookworm
1:7.0.10-1~bpo12+1· arm64 · bookworm-backportsAffected
dsa · suricata · debian · bookworm
[Debian 13 (Trixie)]
- [suricata]Fixed
Details (4)
1:7.0.10-1+deb13u4· amd64 · trixieFixed · Fixed:
1:7.0.10-1+deb13u2dsa · suricata · debian · 13
1:7.0.10-1+deb13u4· arm64 · trixieFixed · Fixed:
1:7.0.10-1+deb13u2dsa · suricata · debian · 13
1:8.0.6-1~bpo13+1· amd64 · trixie-backportsFixed · Fixed:
1:7.0.10-1+deb13u2dsa · suricata · debian · 13
1:8.0.6-1~bpo13+1· arm64 · trixie-backportsFixed · Fixed:
1:7.0.10-1+deb13u2dsa · suricata · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_10082-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-64332]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-64332]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-64332]
- [https://security-tracker.debian.org/tracker/CVE-2025-64332]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-64332.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]