
CVE catalog
CVE-2025-64750
UBUNTU-CVE-2025-64750
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.16% · Oct 25, 2026
SingularityCE and SingularityPRO are open source container platforms. Prior to SingularityCE 4.3.5 and SingularityPRO 4.1.11 and 4.3.5, if a user relies on LSM restrictions to prevent malicious operations then, under certain circumstances, an attacker can redirect the LSM label write operation so that it is ineffective. The attacker must cause the user to run a malicious container image that redirects the mount of /proc to the destination of a shared mount, either known to be configured on the target system, or that will be specified by the user when running the container. The attacker must also control the content of the shared mount, for example through another malicious container which also binds it, or as a user with relevant permissions on the host system it is bound from. This vulnerability is fixed in SingularityCE 4.3.5 and SingularityPRO 4.1.11 and 4.3.5.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | singularity-container | pro | 2.3.1-2 | vulnerable |
| Ubuntu | singularity-container | pro | 2.3.2-1 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.1-1 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.2-2 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.2-3 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.2-4 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.2-4ubuntu0.1~esm1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1build1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.2 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.2+esm1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.3 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.3+esm1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.3+esm2 | vulnerable |
| Ubuntu | singularity-container | 25.10 | 4.1.5+ds4-1 | vulnerable |
| Ubuntu | singularity-container | 26.04 | 4.1.5+ds4-1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: