
CVE catalog
CVE-2025-66037
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, feeding a crafted input to the fuzz_pkcs15_reader harness causes OpenSC to perform an out-of-bounds heap read in the
- Severity
- Low · CVSS 3.9
CVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.25% · Oct 25, 2026
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, feeding a crafted input to the fuzz_pkcs15_reader harness causes OpenSC to perform an out-of-bounds heap read in the X.509/SPKI handling path. Specifically, sc_pkcs15_pubkey_from_spki_fields() allocates a zero-length buffer and then reads one byte past the end of that allocation. This issue has been patched in version 0.27.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | opensc | sid | 0.27.1-3 | fixed |
| Debian | opensc | forky | 0.27.1-3 | fixed |
| Debian | opensc | trixie | 0.26.1-2 | vulnerable |
| Debian | opensc | bookworm | 0.23.0-0.3+deb12u2 | vulnerable |
| Cpe | opensc | Not reported | Not reported | vulnerable |
| Cpe | opensc | Not reported | 0.27.0 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | opensc | source | sid | 0.27.1-1 | not yet assigned | Not reported | Not reported |
| Debian | opensc | source | forky | 0.27.1-1 | not yet assigned | Not reported | Not reported |
| Debian | opensc | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | opensc | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Cpe | opensc | cpe | Not reported | 0.27.0 | Not reported | Not reported | Not reported |
Notes
[trixie] opensc: Minor issue [bookworm] opensc: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [opensc]Affected
Details (2)
0.23.0-0.3+deb12u2· amd64 · bookwormAffected
nvd · opensc · debian · bookworm; nvd · opensc · debian · 12
0.23.0-0.3+deb12u2· arm64 · bookwormAffected
nvd · opensc · debian · bookworm; nvd · opensc · debian · 12
- [opensc-pkcs11]Affected
Source package: [opensc]
Details (2)
0.23.0-0.3+deb12u2· amd64 · bookwormAffected
nvd · opensc · debian · bookworm; nvd · opensc · debian · 12
0.23.0-0.3+deb12u2· arm64 · bookwormAffected
nvd · opensc · debian · bookworm; nvd · opensc · debian · 12
[Debian 13 (Trixie)]
- [opensc]Affected
Details (2)
0.26.1-2· amd64 · trixieAffected
nvd · opensc · debian · 13
0.26.1-2· arm64 · trixieAffected
nvd · opensc · debian · 13
- [opensc-pkcs11]Affected
Source package: [opensc]
Details (2)
0.26.1-2· amd64 · trixieAffected
nvd · opensc · debian · 13
0.26.1-2· arm64 · trixieAffected
nvd · opensc · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-66037]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-66037]
- [https://security-tracker.debian.org/tracker/CVE-2025-66037]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-66037.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-0917.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]