CVE catalog

CVE-2025-66040

DEBIAN-CVE-2025-66040

[CVE catalog]

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.16% · Oct 25, 2026

Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianspotipy132.25.1-1vulnerable
Debianspotipy132.25.2-1vulnerable
Debianspotipy132.26.0-1vulnerable
Debianspotipy142.25.1-1vulnerable
Debianspotipy142.25.2-1fixed
Opensusepython-spotipytumbleweed2.25.2-1.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianspotipydeb142.25.2-1Not reportedDEBIAN-CVE-2025-66040Not reported
Opensusepython-spotipyrpmtumbleweed2.25.2-1.1Not reportedOPENSUSE-SU-2025:15777-1Not reported

OpenFactory catalog packages

[Debian 13 (Trixie)]

  • [python3-spotipy]Affected

    Source package: [spotipy]

    Details (2)
    • 2.25.1-1 · all · trixie

      Affected

      pypi · spotipy · debian · 13

    • 2.25.1-1 · all · trixie

      Affected

      pypi · spotipy · debian · 13

[openSUSE Tumbleweed]

  • Source package: [python-spotipy]

    Details (1)
    • 2.26.0-1.3 · noarch · tumbleweed

      Unknown · Fixed: 2.25.2-1.1

      Version impact unknown

      pypi · python-spotipy · opensuse · tumbleweed

  • Source package: [python-spotipy]

    Details (1)
    • 2.26.0-1.3 · noarch · tumbleweed

      Unknown · Fixed: 2.25.2-1.1

      Version impact unknown

      pypi · python-spotipy · opensuse · tumbleweed

Observed:

References