
CVE catalog
CVE-2025-66215
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, an attacker with physical access to the computer at the time user or administrator uses a token can cause a stack-buf
- Severity
- Low · CVSS 3.8
CVSS:3.1/AV:P/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.16% · Oct 25, 2026
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, an attacker with physical access to the computer at the time user or administrator uses a token can cause a stack-buffer-overflow WRITE in card-oberthur. The attack requires crafted USB device or smart card that would present the system with specially crafted responses to the APDUs. This issue has been patched in version 0.27.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | opensc | sid | 0.27.1-3 | fixed |
| Debian | opensc | forky | 0.27.1-3 | fixed |
| Debian | opensc | trixie | 0.26.1-2 | vulnerable |
| Debian | opensc | bookworm | 0.23.0-0.3+deb12u2 | vulnerable |
| Cpe | opensc | Not reported | Not reported | vulnerable |
| Cpe | opensc | Not reported | 0.27.0 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | opensc | source | sid | 0.27.0~rc1-1 | not yet assigned | Not reported | Not reported |
| Debian | opensc | source | forky | 0.27.0~rc1-1 | not yet assigned | Not reported | Not reported |
| Debian | opensc | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | opensc | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Cpe | opensc | cpe | Not reported | 0.27.0 | Not reported | Not reported | Not reported |
Notes
[trixie] opensc: Minor issue [bookworm] opensc: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [opensc]Affected
Details (2)
0.23.0-0.3+deb12u2· amd64 · bookwormAffected
nvd · opensc · debian · bookworm; nvd · opensc · debian · 12
0.23.0-0.3+deb12u2· arm64 · bookwormAffected
nvd · opensc · debian · bookworm; nvd · opensc · debian · 12
- [opensc-pkcs11]Affected
Source package: [opensc]
Details (2)
0.23.0-0.3+deb12u2· amd64 · bookwormAffected
nvd · opensc · debian · bookworm; nvd · opensc · debian · 12
0.23.0-0.3+deb12u2· arm64 · bookwormAffected
nvd · opensc · debian · bookworm; nvd · opensc · debian · 12
[Debian 13 (Trixie)]
- [opensc]Affected
Details (2)
0.26.1-2· amd64 · trixieAffected
nvd · opensc · debian · 13
0.26.1-2· arm64 · trixieAffected
nvd · opensc · debian · 13
- [opensc-pkcs11]Affected
Source package: [opensc]
Details (2)
0.26.1-2· amd64 · trixieAffected
nvd · opensc · debian · 13
0.26.1-2· arm64 · trixieAffected
nvd · opensc · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-66215]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-66215]
- [https://security-tracker.debian.org/tracker/CVE-2025-66215]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-66215.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-0917.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]