
CVE catalog
CVE-2025-66399
cacti: CVE-2025-66399
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 10.81% · Oct 25, 2026
Cacti is an open source performance and fault management framework. Prior to 1.2.29, there is an input-validation flaw in the SNMP device configuration functionality. An authenticated Cacti user can supply crafted SNMP community strings containing control characters (including newlines) that are accepted, stored verbatim in the database, and later embedded into backend SNMP operations. In environments where downstream SNMP tooling or wrappers interpret newline-separated tokens as command boundaries, this can lead to unintended command execution with the privileges of the Cacti process. This vulnerability is fixed in 1.2.29.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | cacti | sid | 1.2.31+ds1-4 | fixed |
| Debian | cacti | forky | 1.2.31+ds1-4 | fixed |
| Debian | cacti | trixie | 1.2.30+ds1-1 | fixed |
| Debian | cacti | bookworm | 1.2.24+ds1-1+deb12u5 | vulnerable |
| Debian | cacti | bookworm-security | 1.2.24+ds1-1+deb12u5 | vulnerable |
| Cpe | cacti | Not reported | 1.2.29 | fixed |
| Ubuntu | cacti | pro | 1.2.16+ds1-2ubuntu1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1+esm1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1+esm1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1+esm2 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.25+ds1-2 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.26+ds1-1 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.26+ds1-1ubuntu0.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | cacti | source | sid | 1.2.30+ds1-1 | not yet assigned | Not reported | Not reported |
| Debian | cacti | source | forky | 1.2.30+ds1-1 | not yet assigned | Not reported | Not reported |
| Debian | cacti | source | trixie | 1.2.30+ds1-1 | not yet assigned | Not reported | Not reported |
| Debian | cacti | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Cpe | cacti | cpe | Not reported | 1.2.29 | Not reported | NVD-CVE-2025-66399 | Not reported |
Notes
[trixie] cacti: Minor issue [bookworm] cacti: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [cacti]Affected
Details (4)
1.2.24+ds1-1+deb12u5· all · bookwormAffected
dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookwormAffected
dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookworm-securityAffected
dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookworm-securityAffected
dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
[Debian 13 (Trixie)]
- [cacti]Fixed
Details (2)
1.2.30+ds1-1· all · trixieFixed · Fixed:
1.2.30+ds1-1dsa · cacti · debian · 13
1.2.30+ds1-1· all · trixieFixed · Fixed:
1.2.30+ds1-1dsa · cacti · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-66399]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-66399]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-66399]
- [https://security-tracker.debian.org/tracker/CVE-2025-66399]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-66399.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-2720.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]