
CVE catalog
CVE-2025-66412
angular.js: CVE-2025-66412
- Severity
- High · CVSS 8.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.41% · Oct 25, 2026
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 21.0.2, 20.3.15, and 19.2.17, A Stored Cross-Site Scripting (XSS) vulnerability has been identified in the Angular Template Compiler. It occurs because the compiler's internal security schema is incomplete, allowing attackers to bypass Angular's built-in security sanitization. Specifically, the schema fails to classify certain URL-holding attributes (e.g., those that could contain javascript: URLs) as requiring strict URL security, enabling the injection of malicious scripts. This vulnerability is fixed in 21.0.2, 20.3.15, and 19.2.17.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | angular.js | sid | 1.8.3-3 | not affected |
| Debian | angular.js | trixie | 1.8.3-3 | not affected |
| Debian | angular.js | bookworm | 1.8.3-1+deb12u1 | not affected |
| Cpe | angular | Not reported | 21.0.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | angular.js | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | angular.js | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | angular.js | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Cpe | angular | cpe | Not reported | 21.0.2 | Not reported | NVD-CVE-2025-66412 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libjs-angularjs]Not affected
Source package: [angular.js]
Details (2)
1.8.3-1+deb12u1· all · bookwormNot affected
dsa · angular.js · debian · bookworm
1.8.3-1+deb12u1· all · bookwormNot affected
dsa · angular.js · debian · bookworm
Observed:
References
- [https://cert-portal.siemens.com/productcert/csaf/ssa-485750.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-66412]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-66412]
- [https://security-tracker.debian.org/tracker/CVE-2025-66412]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-66412.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-0778.json]
[CERT-Bund public advisories] · [CISA cybersecurity advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]