
CVE catalog
CVE-2025-66566
lz4-java: CVE-2025-66566
- Severity
- High · CVSS 8.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.60% · Oct 25, 2026
yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations are not affected. This vulnerability is fixed in 1.10.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | lz4-java | sid | 1.11.2+ds1-3 | fixed |
| Debian | lz4-java | forky | 1.11.2+ds1-3 | fixed |
| Debian | lz4-java | trixie | 1.8.0-4 | vulnerable |
| Debian | lz4-java | bookworm | 1.8.0-3 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | lz4-java | source | sid | 1.11.2+ds1-1 | not yet assigned | Not reported | [1122026] |
| Debian | lz4-java | source | forky | 1.11.2+ds1-1 | not yet assigned | Not reported | [1122026] |
| Debian | lz4-java | source | trixie | (unfixed) | not yet assigned | Not reported | [1122026] |
| Debian | lz4-java | source | bookworm | (unfixed) | not yet assigned | Not reported | [1122026] |
Notes
[trixie] lz4-java: Minor issue [bookworm] lz4-java: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [liblz4-java]Affected
Source package: [lz4-java]
Details (2)
1.8.0-3· all · bookwormAffected
dsa · lz4-java · debian · bookworm; dsa · lz4-java · debian · 12
1.8.0-3· all · bookwormAffected
dsa · lz4-java · debian · bookworm; dsa · lz4-java · debian · 12
- [liblz4-jni]Affected
Source package: [lz4-java]
Details (2)
1.8.0-3· amd64 · bookwormAffected
dsa · lz4-java · debian · bookworm; dsa · lz4-java · debian · 12
1.8.0-3· arm64 · bookwormAffected
dsa · lz4-java · debian · bookworm; dsa · lz4-java · debian · 12
[Debian 13 (Trixie)]
- [liblz4-java]Affected
Source package: [lz4-java]
Details (2)
1.8.0-4· all · trixieAffected
dsa · lz4-java · debian · 13
1.8.0-4· all · trixieAffected
dsa · lz4-java · debian · 13
- [liblz4-jni]Affected
Source package: [lz4-java]
Details (2)
1.8.0-4· amd64 · trixieAffected
dsa · lz4-java · debian · 13
1.8.0-4+b1· arm64 · trixieAffected
dsa · lz4-java · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2026_0751.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2025-66566]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-66566]
- [https://security-tracker.debian.org/tracker/CVE-2025-66566]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-66566.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-0800.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]