
CVE catalog
CVE-2025-66567
The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix
- Severity
- Critical · CVSS 9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.42% · Oct 25, 2026
The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-saml | bookworm | 1.13.0-1+deb12u1 | not affected |
| Debian | ruby-saml | bookworm-security | 1.13.0-1+deb12u1 | not affected |
| Cpe | ruby-saml | Not reported | 1.18.0 | fixed |
| Ubuntu | ruby-saml | pro | 1.15.0-1 | vulnerable |
| Ubuntu | ruby-saml | pro | 1.15.0-1ubuntu0.24.04.1 | vulnerable |
| Ubuntu | ruby-saml | pro | 1.15.0-1ubuntu0.24.04.1+esm1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-saml | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Cpe | ruby-saml | cpe | Not reported | 1.18.0 | Not reported | NVD-CVE-2025-66567 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ruby-saml]Not affected
Details (4)
1.13.0-1+deb12u1· all · bookwormNot affected
nvd · ruby-saml · debian · bookworm
1.13.0-1+deb12u1· all · bookwormNot affected
nvd · ruby-saml · debian · bookworm
1.13.0-1+deb12u1· all · bookworm-securityNot affected
nvd · ruby-saml · debian · bookworm
1.13.0-1+deb12u1· all · bookworm-securityNot affected
nvd · ruby-saml · debian · bookworm
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-66567]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-66567]
- [https://security-tracker.debian.org/tracker/CVE-2025-66567]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-2764.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]