
CVE catalog
CVE-2025-66648
vega.js: CVE-2025-66648
- Severity
- High · CVSS 7.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.23% · Oct 25, 2026
vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions `6.1.1`. There is no workaround besides upgrading. Using `vega.expressionInterpreter` as described in CSP safe mode does not prevent this issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | vega.js | sid | 5.33.1+ds+~cs5.3.0-4 | fixed |
| Debian | vega.js | forky | 5.33.1+ds+~cs5.3.0-4 | fixed |
| Debian | vega.js | trixie | 5.28.0+ds+~cs5.3.0-1 | vulnerable |
| Debian | vega.js | bookworm | 5.22.1+ds+~3.1.0-4 | vulnerable |
| Cpe | vega-functions | Not reported | 6.1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | vega.js | source | sid | 5.33.1+ds+~cs5.3.0-2 | not yet assigned | Not reported | [1125185] |
| Debian | vega.js | source | forky | 5.33.1+ds+~cs5.3.0-2 | not yet assigned | Not reported | [1125185] |
| Debian | vega.js | source | trixie | (unfixed) | not yet assigned | Not reported | [1125185] |
| Debian | vega.js | source | bookworm | (unfixed) | not yet assigned | Not reported | [1125185] |
| Cpe | vega-functions | cpe | Not reported | 6.1.1 | Not reported | NVD-CVE-2025-66648 | Not reported |
Notes
[trixie] vega.js: Minor issue [bookworm] vega.js: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libjs-vega]Affected
Source package: [vega.js]
Details (2)
5.22.1+ds+~3.1.0-4· all · bookwormAffected
dsa · vega.js · debian · bookworm
5.22.1+ds+~3.1.0-4· all · bookwormAffected
dsa · vega.js · debian · bookworm
- [node-vega]Affected
Source package: [vega.js]
Details (2)
5.22.1+ds+~3.1.0-4· all · bookwormAffected
dsa · vega.js · debian · bookworm
5.22.1+ds+~3.1.0-4· all · bookwormAffected
dsa · vega.js · debian · bookworm
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-66648]
- [https://osv.dev/vulnerability/CVE-2025-66648]
- [https://security-tracker.debian.org/tracker/CVE-2025-66648]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-66648.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]