
CVE catalog
CVE-2025-67746
composer: CVE-2025-67746
- Severity
- Low · CVSS 3.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.45% · Oct 25, 2026
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | composer | sid | 2.10.3-1 | fixed |
| Debian | composer | forky | 2.10.3-1 | fixed |
| Debian | composer | trixie | 2.8.8-1+deb13u3 | fixed |
| Debian | composer | bookworm | 2.5.5-1+deb12u5 | fixed |
| Debian | composer | bookworm-security | 2.5.5-1+deb12u2 | vulnerable |
| Suse | php-composer2 | linux enterprise server 16.0 | 2.8.9-160000.4.1 | fixed |
| Suse | php-composer2 | linux enterprise server for sap applications 16.0 | 2.8.9-160000.4.1 | fixed |
| Suse | php-composer2 | linux enterprise server 16.0 | 2.8.9-160000.4.1 | fixed |
| Suse | php-composer2 | linux enterprise server for sap applications 16.0 | 2.8.9-160000.4.1 | fixed |
| Opensuse | php-composer2 | leap 16.0 | 2.8.9-160000.4.1 | fixed |
| Ubuntu | composer | pro | 2.5.8-1 | vulnerable |
| Ubuntu | composer | pro | 2.6.5-1 | vulnerable |
| Ubuntu | composer | pro | 2.6.6-1 | vulnerable |
| Ubuntu | composer | pro | 2.7.1-2 | vulnerable |
| Ubuntu | composer | pro | 2.7.1-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | composer | 25.10 | 2.8.6-1 | vulnerable |
| Ubuntu | composer | 25.10 | 2.8.8-1 | vulnerable |
| Ubuntu | composer | 26.04 | 2.8.8-1 | vulnerable |
| Ubuntu | composer | 26.04 | 2.9.5-1 | vulnerable |
| Opensuse | php-composer2 | tumbleweed | 2.9.3-1.1 | fixed |
| Suse | php-composer2 | linux enterprise module for web and scripting 15 sp7 | 2.6.4-150600.3.6.1 | fixed |
| Opensuse | php-composer2 | leap 15.6 | 2.6.4-150600.3.6.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | composer | source | sid | 2.9.3-1 | not yet assigned | Not reported | Not reported |
| Debian | composer | source | forky | 2.9.3-1 | not yet assigned | Not reported | Not reported |
| Debian | composer | source | trixie | 2.8.8-1+deb13u1 | not yet assigned | Not reported | Not reported |
| Debian | composer | source | bookworm | 2.5.5-1+deb12u3 | not yet assigned | Not reported | Not reported |
| Suse | php-composer2 | rpm | linux enterprise server 16.0 | 2.8.9-160000.4.1 | Not reported | SUSE-SU-2026:23138-1 | Not reported |
| Suse | php-composer2 | rpm | linux enterprise server for sap applications 16.0 | 2.8.9-160000.4.1 | Not reported | SUSE-SU-2026:23138-1 | Not reported |
| Suse | php-composer2 | rpm | linux enterprise server 16.0 | 2.8.9-160000.4.1 | Not reported | SUSE-SU-2026:23116-1 | Not reported |
| Suse | php-composer2 | rpm | linux enterprise server for sap applications 16.0 | 2.8.9-160000.4.1 | Not reported | SUSE-SU-2026:23116-1 | Not reported |
| Opensuse | php-composer2 | rpm | leap 16.0 | 2.8.9-160000.4.1 | Not reported | OPENSUSE-SU-2026:21520-1 | Not reported |
| Opensuse | php-composer2 | rpm | tumbleweed | 2.9.3-1.1 | Not reported | OPENSUSE-SU-2026:10054-1 | Not reported |
| Suse | php-composer2 | rpm | linux enterprise module for web and scripting 15 sp7 | 2.6.4-150600.3.6.1 | Not reported | SUSE-SU-2026:0825-1 | Not reported |
| Opensuse | php-composer2 | rpm | leap 15.6 | 2.6.4-150600.3.6.1 | Not reported | SUSE-SU-2026:0825-1 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [composer]Affected
Details (4)
2.5.5-1+deb12u5· all · bookwormFixed · Fixed:
2.5.5-1+deb12u3dsa · composer · debian · bookworm; dsa · composer · debian · 12
2.5.5-1+deb12u5· all · bookwormFixed · Fixed:
2.5.5-1+deb12u3dsa · composer · debian · bookworm; dsa · composer · debian · 12
2.5.5-1+deb12u2· all · bookworm-securityAffected · Fixed:
2.5.5-1+deb12u3dsa · composer · debian · bookworm; dsa · composer · debian · 12
2.5.5-1+deb12u2· all · bookworm-securityAffected · Fixed:
2.5.5-1+deb12u3dsa · composer · debian · bookworm; dsa · composer · debian · 12
[Debian 13 (Trixie)]
- [composer]Fixed
Details (2)
2.8.8-1+deb13u3· all · trixieFixed · Fixed:
2.8.8-1+deb13u1dsa · composer · debian · 13
2.8.8-1+deb13u3· all · trixieFixed · Fixed:
2.8.8-1+deb13u1dsa · composer · debian · 13
[openSUSE Tumbleweed]
- [php-composer2]Fixed
Source package: [php-composer2]
Details (1)
2.10.3-1.1· noarch · tumbleweedFixed · Fixed:
2.9.3-1.1dsa · php-composer2 · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2026_3105-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-67746]
- [https://osv.dev/vulnerability/SUSE-SU-2026:0825-1]
- [https://osv.dev/vulnerability/SUSE-SU-2026:23116-1]
- [https://osv.dev/vulnerability/SUSE-SU-2026:23138-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-67746]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:10054-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:21520-1]
- [https://security-tracker.debian.org/tracker/CVE-2025-67746]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-67746.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]